aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-06-23 15:50:18 +0300
committerViorel Munteanu <ceamac@gentoo.org>2024-06-23 15:51:21 +0300
commit8bd7568b34fcbb11ebe5559d42c75ead21036e99 (patch)
tree5c4b3decbb1dead2670ab4e8092315647c5e5813
parentgames-util/legendary: enable py3.12 (diff)
downloadguru-8bd7568b34fcbb11ebe5559d42c75ead21036e99.tar.gz
guru-8bd7568b34fcbb11ebe5559d42c75ead21036e99.tar.bz2
guru-8bd7568b34fcbb11ebe5559d42c75ead21036e99.zip
dev-python/desktop-notifier: add 5.0.0
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
-rw-r--r--dev-python/desktop-notifier/Manifest1
-rw-r--r--dev-python/desktop-notifier/desktop-notifier-5.0.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/desktop-notifier/Manifest b/dev-python/desktop-notifier/Manifest
index 232ee9755..7dfe129a8 100644
--- a/dev-python/desktop-notifier/Manifest
+++ b/dev-python/desktop-notifier/Manifest
@@ -1 +1,2 @@
DIST desktop_notifier-4.0.0.tar.gz 29934 BLAKE2B da9944edd6577f36116a03a6620a5a8ec68071954df4ac31a96af148608a9c6d990805f025b44925a943274bc961d4412690dde7876520f9a42bca0b6b008f9b SHA512 a96f96d6cbf7876bebcc9eb8a33d348eb5ed8f2a86fd5a9761105684e0267d9496904bb38f54caba39d29dfc23e00530655669d8e849607e066c85512f67c045
+DIST desktop_notifier-5.0.0.tar.gz 32685 BLAKE2B 15f57cf1307fae127317da5590cdf7956a47741776ffc82d830ef634bea2ed059b8e7a392a214240fee6ba2c5073b2630cb4479d2fc3239a8bb92aa2146dd640 SHA512 d3eba090863e9c236e778680e9866c65b9fe584bd238e3819f4ae12cab570847708d70bfab81cd0e928a3945d5f339bf8d275fbf5709fbbe36f2a16a9544baca
diff --git a/dev-python/desktop-notifier/desktop-notifier-5.0.0.ebuild b/dev-python/desktop-notifier/desktop-notifier-5.0.0.ebuild
new file mode 100644
index 000000000..f938fb500
--- /dev/null
+++ b/dev-python/desktop-notifier/desktop-notifier-5.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="desktop-notifier is a Python library for cross-platform desktop notifications"
+HOMEPAGE="
+ https://desktop-notifier.readthedocs.io
+ https://pypi.org/project/desktop-notifier/
+ https://github.com/samschott/desktop-notifier
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/dbus-next[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/build[${PYTHON_USEDEP}]
+"
+
+# Tests on pypi are incomplete
+# Tests on gh don't work
+RESTRICT="test"