aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-11-16 13:14:25 -0500
committerJulien Roy <julien@jroy.ca>2024-11-16 15:19:56 -0500
commit6760193886a86dc09a28004613bf55de0fbaa2ae (patch)
tree7772eeb1e31fb5f162af98bd073043895387e3ee
parentnet-im/mautrix-meta: drop 0.3.0 (diff)
downloadguru-6760193886a86dc09a28004613bf55de0fbaa2ae.tar.gz
guru-6760193886a86dc09a28004613bf55de0fbaa2ae.tar.bz2
guru-6760193886a86dc09a28004613bf55de0fbaa2ae.zip
net-im/mautrix-slack: add 0.1.3
Signed-off-by: Julien Roy <julien@jroy.ca>
-rw-r--r--net-im/mautrix-slack/Manifest2
-rw-r--r--net-im/mautrix-slack/mautrix-slack-0.1.3.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/net-im/mautrix-slack/Manifest b/net-im/mautrix-slack/Manifest
index 4585ca204..a8e76c306 100644
--- a/net-im/mautrix-slack/Manifest
+++ b/net-im/mautrix-slack/Manifest
@@ -1,3 +1,5 @@
+DIST mautrix-slack-0.1.3-deps.tar.xz 30422444 BLAKE2B 5a7cb539960b9a4facfc940d5ace829ec182e43af4c92d3d79ad8ced436293fbc74d29464f0e9c4e023b0ad2113ba57ddc93c8fac2d94f9c3a6aaad7bdccd472 SHA512 37bd80f215b5bcce647d4b0b9540fac30ecc149826f3fb800a5a21ccaf220e9ce767c2259f6577de30b079b3a9cf0ccac2613359d51dd929eedfae98e7850e5a
+DIST mautrix-slack-0.1.3.gh.tar.gz 98604 BLAKE2B a88d559a02547300085262178074a05cfb394c820068602444e0f91c8981e1e8dc8635f51592ff7e9d0fe0501895fd7c65826e49590ee91a86904b06957bbdb8 SHA512 c5a1620d6df80f1c2aae7f7390a31de1dc3dc962792a8582f910499aad89dd4951ac1b6c778388da1fe32ee86c13091f37fc4907847f4ed8d4a01241654ac780
DIST mautrix-slack-0_pre20230925.gh.tar.gz 98793 BLAKE2B 3172f0b274da2f95897cec163bd82090668de0ee8d8a4dfc2e20ec65cf764d8a6270a3801a72efc0b16cef6275c4b767e2728715736878354533de475fb23ea0 SHA512 d2bd2b4a52233d2ce59c7fde956ae253c97c6e28913b479fd64708759fceae8154dc71d54dadb8d515fccf6a5a43c0b77a94d0938e4c2a8333a18ac9b7965a7f
DIST mautrix-slack-0_pre20230925.tar.xz 15741728 BLAKE2B 8f107120e688fedf925a219fc317afaa7f19b97951dc48ba9de75596d3866d549775d169eeaaa4747151f82bdb101b901018430d1f29907e66c122892ce8f908 SHA512 59d1879ac30feee322dc17af04a651db193ecf688aba2308411ee4534c3c0d824cbce199315c1345f296c7e787d35fc19bc8cf9447169947c889f0fd2d1dd219
DIST mautrix-slack-0_pre20240215.gh.tar.gz 98878 BLAKE2B 1c2fe565990d2ab0a1cb39c72b4bd3c8b9fcbb18978e785a1ad6f994d01a59b047f127db4c1dfa291dfae97d81f82c64200d1ccb10b5ade27391fdde40794529 SHA512 68636ee04a41f152f4a7d75e9ad6937ded86da84327031a04a17fdf9260422a2717f133fc6b1c25dc3364877d5f08e8915420a5f1e19a51957d6dcd6d364c697
diff --git a/net-im/mautrix-slack/mautrix-slack-0.1.3.ebuild b/net-im/mautrix-slack/mautrix-slack-0.1.3.ebuild
new file mode 100644
index 000000000..9aa9e4269
--- /dev/null
+++ b/net-im/mautrix-slack/mautrix-slack-0.1.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module systemd
+
+DESCRIPTION="A Matrix-Slack puppeting bridge based on slack-go"
+HOMEPAGE="https://github.com/mautrix/slack"
+SRC_URI="https://github.com/mautrix/slack/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz
+ https://jroy.ca/dist/${P}-deps.tar.xz
+"
+S="${WORKDIR}/slack-${PV}"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ acct-user/${PN}
+ dev-libs/olm
+"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ ego build "${S}"/cmd/"${PN}"
+}
+
+src_install() {
+ dobin mautrix-slack
+
+ keepdir /var/log/mautrix/slack
+ fowners -R root:mautrix /var/log/mautrix
+ fperms -R 770 /var/log/mautrix
+ sed -i -e "s/\.\/logs/\/var\/log\/mautrix\/slack/" "${S}/pkg/connector/example-config.yaml" || die
+
+ insinto "/etc/mautrix"
+ newins "${S}/pkg/connector/example-config.yaml" "${PN/-/_}.yaml"
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+
+ fowners -R root:mautrix /etc/mautrix
+ fperms -R 770 /etc/mautrix
+}
+
+pkg_postinst() {
+ einfo
+ elog ""
+ elog "Before you can use ${PN}, you must configure it correctly"
+ elog "The configuration file is located at \"/etc/mautrix/${PN/-/_}.yaml\""
+ elog "When done, run the following command: emerge --config ${CATEGORY}/${PN}"
+ elog "Then, you must register the bridge with your homeserver"
+ elog "Refer your homeserver's documentation for instructions"
+ elog "The registration file is located at /var/lib/${PN/-/\/}/registration.yaml"
+ elog "Finally, you may start the ${PN} daemon"
+ einfo
+}
+
+pkg_config() {
+ su - "${PN}" -s /bin/sh -c \
+ "/usr/bin/${PN} -c /etc/mautrix/${PN/-/_}.yaml -g -r /var/lib/${PN/-/\/}/registration.yaml"
+}