aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-10-19 19:13:09 +0300
committerViorel Munteanu <ceamac@gentoo.org>2023-10-19 19:14:17 +0300
commit6167283a9759174ed30a56e6b0f2692447653fae (patch)
tree2b01cfd8ceb3aa687cee71522ae282ac099bb7f7
parentmpv-plugin/mpv_thumbnail_script: add 0.5.3 (diff)
downloadguru-6167283a9759174ed30a56e6b0f2692447653fae.tar.gz
guru-6167283a9759174ed30a56e6b0f2692447653fae.tar.bz2
guru-6167283a9759174ed30a56e6b0f2692447653fae.zip
dev-python/Pyro5: disable failing test
It looks harmelss and it is pypy3 specific. Informed upstream. Require python[sqlite]. Closes: https://bugs.gentoo.org/915997 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
-rw-r--r--dev-python/Pyro5/Pyro5-5.15-r1.ebuild (renamed from dev-python/Pyro5/Pyro5-5.15.ebuild)2
1 files changed, 2 insertions, 0 deletions
diff --git a/dev-python/Pyro5/Pyro5-5.15.ebuild b/dev-python/Pyro5/Pyro5-5.15-r1.ebuild
index 5604b18bb..fb02557a5 100644
--- a/dev-python/Pyro5/Pyro5-5.15.ebuild
+++ b/dev-python/Pyro5/Pyro5-5.15-r1.ebuild
@@ -3,6 +3,7 @@
EAPI=8
+PYTHON_REQ_USE="sqlite"
PYTHON_COMPAT=( python3_{10..12} pypy3 )
DISTUTILS_USE_PEP517=setuptools
@@ -31,6 +32,7 @@ distutils_enable_sphinx docs/source \
EPYTEST_DESELECT=(
tests/test_socketutil.py::TestSocketutil::testGetInterface # https://github.com/irmen/Pyro5/issues/82
+ tests/test_server.py::TestServerOnce::testRegisterWeak # https://github.com/irmen/Pyro5/issues/83 (pypy3 specific)
)
python_test() {