aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-11-17 06:09:48 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2024-11-17 07:03:12 +0500
commit4980da12d25b9e1ab50038c2d306b5857deabc75 (patch)
tree65b5522ce30e504492d5281b883dc0cc43c2c21c
parentphosh-base/phosh-tour: add 0.43.0 (diff)
downloadguru-4980da12d25b9e1ab50038c2d306b5857deabc75.tar.gz
guru-4980da12d25b9e1ab50038c2d306b5857deabc75.tar.bz2
guru-4980da12d25b9e1ab50038c2d306b5857deabc75.zip
phosh-base/phosh-mobile-settings: add 0.43.0
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
-rw-r--r--phosh-base/phosh-mobile-settings/Manifest2
-rw-r--r--phosh-base/phosh-mobile-settings/phosh-mobile-settings-0.43.0.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/phosh-base/phosh-mobile-settings/Manifest b/phosh-base/phosh-mobile-settings/Manifest
index 6ae4a98dc..9e3b805a5 100644
--- a/phosh-base/phosh-mobile-settings/Manifest
+++ b/phosh-base/phosh-mobile-settings/Manifest
@@ -2,3 +2,5 @@ DIST phosh-mobile-settings-0.41.0.tar.xz 216932 BLAKE2B ea1ff3ff6275749dd75a0468
DIST phosh-mobile-settings-0.41.0.tar.xz.asc 833 BLAKE2B 8a196701a49e2ade05537a11bf3f34738e64e9c6276d713e5cff17953bb2427304189600aebd80a2163a0a2af626467c409e2d3a5d7f6eb43464a0025468b260 SHA512 9ac92d75e9d0c3a16ad6ff6eb7926e182a9eae94fe621cf1815e51ff552dd1736b13f3fa3ebf5f4c4c21adddc9c082e4493e70a8b5bebe9c5a2f27e1655c692d
DIST phosh-mobile-settings-0.42.0.tar.xz 229020 BLAKE2B 166f6cf54b634b2a935ff3fd63756d7935ce61afe9192afaacb3544eb96e605fc0d702e65eb8e2068f9cf4aab3a6ede4ac523ceaf2cea46a0085dcf4d1d6f4e5 SHA512 aebb741ae1ad508610600ab24495442cff959d883c12529f47b9eb3cf822d03dcf4b9d0e8605dd77820861899329c2133bdad566567b50a009d180a0141dcfc3
DIST phosh-mobile-settings-0.42.0.tar.xz.asc 833 BLAKE2B e481795aa52593b5655a970c5454b051e424312df3ba1b45fa6bff8ef4b54149bb0166a7fec80990cad5b554ada495f1fae2799f713290082390430f1faf093b SHA512 69cbc847ed5e3d31dafd386e97b5e8a7009da6ecc19df9715fff527c568f34e3d78dcd54d5e3800e7437ca1bc30cb726891eb72bf15cd225ad8618e035ad1978
+DIST phosh-mobile-settings-0.43.0.tar.xz 236724 BLAKE2B 29f15d9f1bb6717f49c604a2fd802d1e595d376d31c44011255a381e4ba744bf0409c2a6d105c647de3182c7cdd050de5f0a1a50b3cae51ff97300ec35796267 SHA512 e7357379acdbcf94067435116f1cc5e83461f3e87193f7d202dbe9fdf90dd9beaef0aa20c84cd5249be1c0ec27b19aaff6d1d053ea14facfb21a2c7c418b2882
+DIST phosh-mobile-settings-0.43.0.tar.xz.asc 833 BLAKE2B 336edf65970fe4b13345e93393c6dfc41edfbea41a9b156cefb3ecb0e55c08992ee552ff3c8a2af1995c5b1f2bcfc20c153c86c4431a68b7d022e3f462f894e6 SHA512 4f6001fd2b745acccc8db658f2953b41dd9d5e71b1a752acec52536ccccc9fd9d691da1df6f88ce6e5cf328b07c901c37ba742e20f1d2030ee87f3a0f6ab9cc9
diff --git a/phosh-base/phosh-mobile-settings/phosh-mobile-settings-0.43.0.ebuild b/phosh-base/phosh-mobile-settings/phosh-mobile-settings-0.43.0.ebuild
new file mode 100644
index 000000000..0461b1d88
--- /dev/null
+++ b/phosh-base/phosh-mobile-settings/phosh-mobile-settings-0.43.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils meson verify-sig xdg
+
+DESCRIPTION="Mobile Settings App for phosh and related components"
+HOMEPAGE="https://gitlab.gnome.org/guidog/phosh-mobile-settings"
+SRC_URI="https://sources.phosh.mobi/releases/${PN}/${P}.tar.xz
+ verify-sig? ( https://sources.phosh.mobi/releases/${PN}/${P}.tar.xz.asc )"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.76:2
+ >=dev-libs/gmobile-0.2.1
+ >=dev-libs/json-glib-1.6.2
+ >=dev-libs/wayland-1.14
+ >=gnome-base/gnome-desktop-44:4=
+ >=gui-libs/gtk-4.12.5:4[wayland]
+ >=gui-libs/libadwaita-1.5:1
+ media-libs/gsound
+ >=phosh-base/phosh-shell-0.40.0
+ sys-apps/lm-sensors:=
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/wayland-protocols-1.12
+"
+RDEPEND="${COMMON_DEPEND}
+ dev-libs/feedbackd
+ >=gui-wm/phoc-0.34.0
+"
+BDEPEND="
+ dev-libs/glib:2
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/wayland-scanner
+ sys-devel/gettext
+ verify-sig? ( sec-keys/openpgp-keys-phosh )
+"
+
+VERIFY_SIG_OPENPGP_KEY_PATH="/usr/share/openpgp-keys/phosh.asc"
+
+QA_DESKTOP_FILE="usr/share/applications/mobi.phosh.MobileSettings.desktop"
+
+src_test() {
+ # No useful tests
+ :
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}