aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2023-10-17 13:50:01 -0400
committerJulien Roy <julien@jroy.ca>2023-10-17 13:50:11 -0400
commit464defa47f7c0a7e813e95ca9eface0821d6a348 (patch)
treed6f73485a478c7b64f77b56918b9cad002cd5b03
parentsci-electronics/kactus2: enable py3.12 (diff)
downloadguru-464defa47f7c0a7e813e95ca9eface0821d6a348.tar.gz
guru-464defa47f7c0a7e813e95ca9eface0821d6a348.tar.bz2
guru-464defa47f7c0a7e813e95ca9eface0821d6a348.zip
net-im/mautrix-slack: add 0_pre20230925
Signed-off-by: Julien Roy <julien@jroy.ca>
-rw-r--r--net-im/mautrix-slack/Manifest2
-rw-r--r--net-im/mautrix-slack/mautrix-slack-0_pre20230925.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/net-im/mautrix-slack/Manifest b/net-im/mautrix-slack/Manifest
index 04730adc0..15d9b41ae 100644
--- a/net-im/mautrix-slack/Manifest
+++ b/net-im/mautrix-slack/Manifest
@@ -2,3 +2,5 @@ DIST mautrix-slack-0_pre20230414.gh.tar.gz 94370 BLAKE2B 56cb12269fb6695aaf6ed34
DIST mautrix-slack-0_pre20230414.tar.xz 14805340 BLAKE2B 2fabcacf24edca667143c7dfac108932af7edfe8d991331eb9c06c52de1669184942600224907c4dfe690d85a0a19306398c62d6f3e6b8aba4b243dd72eaffc0 SHA512 0f121cf01565a14e1d692b8d646b83c20ecf0082b3c61300fbfeb8a6e5b8f0631ea7c2fc3a9e64e851abb7cf9ec53e1c8e5e20324cd43d71c7e72cb8275cba24
DIST mautrix-slack-0_pre20230517.gh.tar.gz 94370 BLAKE2B 56cb12269fb6695aaf6ed3485166732b5f526e00f6a0237b2c2d1fe7f36eda15bf2ba26560b31069cda3f1229645f64bb99c9e6ce88d6c8d441af4e338071875 SHA512 7374b87892c92ca7dd493d1886bc24a8916931951be8c3e5799d223931a18bbf2d7a93dc02e4c6714f53e1b3c9005272e278a60578859d48f8882b50488de52b
DIST mautrix-slack-0_pre20230517.tar.xz 18026880 BLAKE2B 14623cbf2b3ed3a244f762fee4f816ab38bb2bd9f2d488e3bdd93419b838403e9c3eb50fb473c358c3391788383d382977db23ad3721138f38ad1e022cf18cd2 SHA512 bc9b8cb0b59ca2c196d555c49633f1b00305577e400f11b5430f843a6a166ce708ac62db9d06ea262d2b6e2e3b070395fc7dbe79de6467e6a46d89ae6e3ee5de
+DIST mautrix-slack-0_pre20230925.gh.tar.gz 98793 BLAKE2B 3172f0b274da2f95897cec163bd82090668de0ee8d8a4dfc2e20ec65cf764d8a6270a3801a72efc0b16cef6275c4b767e2728715736878354533de475fb23ea0 SHA512 d2bd2b4a52233d2ce59c7fde956ae253c97c6e28913b479fd64708759fceae8154dc71d54dadb8d515fccf6a5a43c0b77a94d0938e4c2a8333a18ac9b7965a7f
+DIST mautrix-slack-0_pre20230925.tar.xz 15741728 BLAKE2B 8f107120e688fedf925a219fc317afaa7f19b97951dc48ba9de75596d3866d549775d169eeaaa4747151f82bdb101b901018430d1f29907e66c122892ce8f908 SHA512 59d1879ac30feee322dc17af04a651db193ecf688aba2308411ee4534c3c0d824cbce199315c1345f296c7e787d35fc19bc8cf9447169947c889f0fd2d1dd219
diff --git a/net-im/mautrix-slack/mautrix-slack-0_pre20230925.ebuild b/net-im/mautrix-slack/mautrix-slack-0_pre20230925.ebuild
new file mode 100644
index 000000000..b4cce5e11
--- /dev/null
+++ b/net-im/mautrix-slack/mautrix-slack-0_pre20230925.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module systemd
+
+COMMIT="4530ff397d08d93b673cd71da4c2a75d969ca0df"
+DESCRIPTION="A Matrix-Slack puppeting bridge based on slack-go"
+HOMEPAGE="https://github.com/mautrix/slack"
+SRC_URI="https://github.com/mautrix/slack/archive/${COMMIT}.tar.gz -> ${P}.gh.tar.gz
+ https://jroy.ca/dist/${P}.tar.xz
+"
+S="${WORKDIR}/slack-${COMMIT}"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ acct-user/${PN}
+ dev-libs/olm
+"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ ego build
+}
+
+src_install() {
+ dobin mautrix-slack
+
+ keepdir /var/log/mautrix/slack
+ fowners -R root:mautrix /var/log/mautrix
+ fperms -R 770 /var/log/mautrix
+ sed -i -e "s/\.\/logs/\/var\/log\/mautrix\/slack/" "example-config.yaml" || die
+
+ insinto "/etc/mautrix"
+ newins "example-config.yaml" "${PN/-/_}.yaml"
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+
+ fowners -R root:mautrix /etc/mautrix
+ fperms -R 770 /etc/mautrix
+}
+
+pkg_postinst() {
+ einfo
+ elog ""
+ elog "Before you can use ${PN}, you must configure it correctly"
+ elog "The configuration file is located at \"/etc/mautrix/${PN/-/_}.yaml\""
+ elog "When done, run the following command: emerge --config ${CATEGORY}/${PN}"
+ elog "Then, you must register the bridge with your homeserver"
+ elog "Refer your homeserver's documentation for instructions"
+ elog "The registration file is located at /var/lib/${PN/-/\/}/registration.yaml"
+ elog "Finally, you may start the ${PN} daemon"
+ einfo
+}
+
+pkg_config() {
+ su - "${PN}" -s /bin/sh -c \
+ "/usr/bin/${PN} -c /etc/mautrix/${PN/-/_}.yaml -g -r /var/lib/${PN/-/\/}/registration.yaml"
+}