aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2023-10-17 14:20:05 +0200
committerDavid Roman <davidroman96@gmail.com>2023-10-17 14:20:05 +0200
commit0bbd0355ec65fad15f03456648513d037830cadb (patch)
treee09e89c51a9fadfab981657dac23036134d78c28
parentdev-python/PythonQwt: drop 0.10.2 (diff)
downloadguru-0bbd0355ec65fad15f03456648513d037830cadb.tar.gz
guru-0bbd0355ec65fad15f03456648513d037830cadb.tar.bz2
guru-0bbd0355ec65fad15f03456648513d037830cadb.zip
dev-python/python-socketio: add 5.10.0
Signed-off-by: David Roman <davidroman96@gmail.com>
-rw-r--r--dev-python/python-socketio/Manifest1
-rw-r--r--dev-python/python-socketio/python-socketio-5.10.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/python-socketio/Manifest b/dev-python/python-socketio/Manifest
index 3a2d3967b..38c96ee63 100644
--- a/dev-python/python-socketio/Manifest
+++ b/dev-python/python-socketio/Manifest
@@ -1,2 +1,3 @@
+DIST python-socketio-5.10.0.tar.gz 114300 BLAKE2B 134fc3a03f3923afb9ff96f3765c738cf296f875718fb35ccdeade77bae185ed2c5973e1adcdf69e3fcf4b98ecbe0177161c5405ef6782798c5ce355f427ca71 SHA512 e20a88d6031d69c64db777487bfc8cfe043d4e893e73194c82f529290d0852352b5d011d07f4ce82a51e71f34cf483be99a5851eb5969d520fc8126009d7363f
DIST python-socketio-5.8.0.tar.gz 47872 BLAKE2B 465593a89bb0504af485ec4c94a52159548ce3cace3f58c9174d694e35b40c6eb68e5a0350ee34551b6d01c47d571be63f7cc91a42ca9815c2a3a271825f3624 SHA512 653a6764e22738f0aaad3fb03ef193d820780d61fcffede117a2a2cf7097c722974bded7869639f4ac01dc9a121d90dcbeca70fcc9bbb4e96e3b87bd39e69180
DIST python-socketio-5.9.0.tar.gz 47982 BLAKE2B 3fc120b597f92d404972807a40275a5cdb32a38e6e634034c6c4792cc94635dac1c0a911eec75aeaf961358399873c1de1ad6fcf43389ac96c6e5dc48746bced SHA512 145fbcc4a0d089f96d57aabea1b097badea1b9aaf64dc5401503908460e70400ce5c0581184ff574c97cfabce03fda89285223ec03814fa3d33557476d27ffc4
diff --git a/dev-python/python-socketio/python-socketio-5.10.0.ebuild b/dev-python/python-socketio/python-socketio-5.10.0.ebuild
new file mode 100644
index 000000000..f02fa5f93
--- /dev/null
+++ b/dev-python/python-socketio/python-socketio-5.10.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10,11} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python implementation of the Socket.IO realtime server."
+HOMEPAGE="
+ https://python-socketio.readthedocs.org/
+ https://github.com/miguelgrinberg/python-socketio/
+ https://pypi.org/project/python-socketio"
+
+LICENSE="MIT"
+SLOT="0"
+#wait for dev-python/python-engineio
+KEYWORDS="~amd64"
+IUSE="client asyncio-client"
+
+RDEPEND="dev-python/bidict[${PYTHON_USEDEP}]
+ >=dev-python/python-engineio-4.0.0[${PYTHON_USEDEP}]
+ client? ( dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}] )
+ asyncio-client? ( dev-python/aiohttp[${PYTHON_USEDEP}]
+ dev-python/websockets[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# pypi tarball does not contain tests
+RESTRICT="test"