aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2018-03-18 11:12:48 -0700
committerSteve Arnold <nerdboy@gentoo.org>2018-03-18 11:12:48 -0700
commitfbe6b987e0602bdd80d79c7e6977207836353b7f (patch)
treefddd66ddb79a558f28821dc0b69041cc6ec03d1f /www-client
parentxf86-video-armada+libdrm-armada: ebuild cleanup (diff)
downloadarm-fbe6b987e0602bdd80d79c7e6977207836353b7f.tar.gz
arm-fbe6b987e0602bdd80d79c7e6977207836353b7f.tar.bz2
arm-fbe6b987e0602bdd80d79c7e6977207836353b7f.zip
webkit-gtk+midori: version and patch updates
Signed-off-by: Steve Arnold <nerdboy@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/midori/Manifest1
-rw-r--r--www-client/midori/files/midori-0.5.11-libsoup.patch73
-rw-r--r--www-client/midori/files/midori-0.5.11-vala-syntax.patch100
-rw-r--r--www-client/midori/midori-0.5.11-r2.ebuild74
4 files changed, 248 insertions, 0 deletions
diff --git a/www-client/midori/Manifest b/www-client/midori/Manifest
index 1b58197..02df760 100644
--- a/www-client/midori/Manifest
+++ b/www-client/midori/Manifest
@@ -1 +1,2 @@
DIST midori_0.5.10_all_.tar.bz2 1379519 SHA256 702344f68d7f034866a46398e35b3c16a5a5f3e431a5d916ea5efc3eaaa3e46f SHA512 9e615581b2029e2167d13bab3a580cf89b87da4979bb27982f2002b4ddb97e44d27ea910ee60df6479bd0dfa8cbef75217fa1956eb34b13475c99ab25b83f245 WHIRLPOOL 754b5d7b6851a2c0e537c6746d945f9412cf3757c559bcb07e455f555fa67bfc3e29ff08a39517359ba99bd0759252adea3d78f6281d7a07c8411f02da24fdc7
+DIST midori_0.5.11_all_.tar.bz2 1428791 SHA256 96191a96be71144ae848a409fae5a1d6d52a00e583f33122081f47ead9c49c3d SHA512 237310d1f0bf70796474b9ec5be6755927e66acd2b527d04db39696c5e2f7ea2d11f7deb51ba3f5c151a450ab71e642282a1386e34253aaea1d8602ce76ac87d WHIRLPOOL 6825d1b28e269f9fb158458cd4a3ddbdb09ab241ced32c4ccc5df0c1f9a921a275baf0dcdac24aa84c58f7a3371ef74941bcd06a8303c95dd3ffb48d99de6bba
diff --git a/www-client/midori/files/midori-0.5.11-libsoup.patch b/www-client/midori/files/midori-0.5.11-libsoup.patch
new file mode 100644
index 0000000..b560075
--- /dev/null
+++ b/www-client/midori/files/midori-0.5.11-libsoup.patch
@@ -0,0 +1,73 @@
+diff -ur midori-0.5.11/CMakeLists.txt midori-0.5.11_p/CMakeLists.txt
+--- midori-0.5.11/CMakeLists.txt 2015-08-30 13:56:26.000000000 +0200
++++ midori-0.5.11_p/CMakeLists.txt 2016-08-21 21:10:30.117983251 +0200
+@@ -112,13 +112,13 @@
+ sqlite3>=3.6.19
+ gmodule-2.0
+ gio-2.0>=2.32.3
+- libsoup-gnome-2.4>=2.37.1
++ libsoup-2.4>=2.37.1
+ )
+ add_definitions("-DHAVE_LIBXML")
+ add_definitions("-DGIO_VERSION=\"${DEPS_gio-2.0_VERSION}\"")
+-add_definitions("-DLIBSOUP_VERSION=\"${DEPS_libsoup-gnome-2.4_VERSION}\"")
++add_definitions("-DLIBSOUP_VERSION=\"${DEPS_libsoup-2.4_VERSION}\"")
+ set(PKGS posix linux libxml-2.0 sqlite3 gmodule-2.0 gio-2.0 libsoup-2.4)
+-if (${DEPS_libsoup-gnome-2.4_VERSION} VERSION_GREATER "2.40.0")
++if (${DEPS_libsoup-2.4_VERSION} VERSION_GREATER "2.40.0")
+ # valac 0.16 didn't have the bindings yet
+ # For consistency we need to ensure C code makes the same assumptions
+ if (${VALA_VERSION} VERSION_GREATER "0.17.0")
+@@ -126,7 +126,7 @@
+ set(VALAFLAGS ${VALAFLAGS} -D HAVE_LIBSOUP_2_40_0)
+ endif ()
+ endif ()
+-if (${DEPS_libsoup-gnome-2.4_VERSION} VERSION_GREATER "2.48.0")
++if (${DEPS_libsoup-2.4_VERSION} VERSION_GREATER "2.48.0")
+ add_definitions("-DHAVE_LIBSOUP_2_48_0")
+ set(VALAFLAGS ${VALAFLAGS} -D HAVE_LIBSOUP_2_48_0)
+ endif ()
+diff -ur midori-0.5.11/extensions/cookie-manager/cookie-manager.c midori-0.5.11_p/extensions/cookie-manager/cookie-manager.c
+--- midori-0.5.11/extensions/cookie-manager/cookie-manager.c 2015-08-30 13:56:26.000000000 +0200
++++ midori-0.5.11_p/extensions/cookie-manager/cookie-manager.c 2016-08-19 23:19:20.000000000 +0200
+@@ -12,7 +12,7 @@
+ #include "config.h"
+ #include <midori/midori.h>
+ #include "katze/katze.h"
+-#include <libsoup/soup-cookie-jar-sqlite.h>
++#include <libsoup/soup-cookie-jar-db.h>
+
+ #include "cookie-manager.h"
+ #include "cookie-manager-page.h"
+@@ -282,7 +282,7 @@
+ /* setup soup */
+ #ifdef HAVE_WEBKIT2
+ gchar *filename = midori_paths_get_config_filename_for_writing ("cookies.db");
+- priv->jar = soup_cookie_jar_sqlite_new (filename, FALSE);
++ priv->jar = soup_cookie_jar_db_new (filename, FALSE);
+ g_free(filename);
+ #else
+ SoupSession *session = webkit_get_default_session();
+diff -ur midori-0.5.11/midori/midori-session.c midori-0.5.11_p/midori/midori-session.c
+--- midori-0.5.11/midori/midori-session.c 2015-08-30 13:56:26.000000000 +0200
++++ midori-0.5.11_p/midori/midori-session.c 2016-08-19 23:56:30.000000000 +0200
+@@ -17,8 +17,8 @@
+ #include "sokoke.h"
+
+ #include <glib/gi18n-lib.h>
+-#include <libsoup/soup-cookie-jar-sqlite.h>
+-#include <libsoup/soup-gnome-features.h>
++#include <libsoup/soup-cookie-jar-db.h>
++#include <libsoup/soup-types.h>
+
+ #define LIBSOUP_USE_UNSTABLE_REQUEST_API
+ #include <libsoup/soup-cache.h>
+@@ -297,7 +297,7 @@
+ g_object_unref (feature);
+
+ katze_assign (config_file, midori_paths_get_config_filename_for_writing ("cookies.db"));
+- jar = soup_cookie_jar_sqlite_new (config_file, FALSE);
++ jar = soup_cookie_jar_db_new (config_file, FALSE);
+ soup_session_add_feature (session, SOUP_SESSION_FEATURE (jar));
+ g_signal_connect (jar, "changed",
+ G_CALLBACK (midori_session_cookie_jar_changed_cb), settings);
diff --git a/www-client/midori/files/midori-0.5.11-vala-syntax.patch b/www-client/midori/files/midori-0.5.11-vala-syntax.patch
new file mode 100644
index 0000000..3d6c6c4
--- /dev/null
+++ b/www-client/midori/files/midori-0.5.11-vala-syntax.patch
@@ -0,0 +1,100 @@
+diff -ur midori-0.5.11.orig/extensions/adblock/widgets.vala midori-0.5.11/extensions/adblock/widgets.vala
+--- midori-0.5.11.orig/extensions/adblock/widgets.vala 2015-08-30 13:56:26.000000000 +0200
++++ midori-0.5.11/extensions/adblock/widgets.vala 2017-09-30 01:07:04.033922383 +0200
+@@ -227,7 +227,7 @@
+ liststore.get (iter, 0, out sub);
+ if (sub.mutable) {
+ config.remove (sub);
+- liststore.remove (iter);
++ liststore.remove (ref iter);
+ return true;
+ }
+ }
+diff -ur midori-0.5.11.orig/extensions/apps.vala midori-0.5.11/extensions/apps.vala
+--- midori-0.5.11.orig/extensions/apps.vala 2015-08-30 13:56:26.000000000 +0200
++++ midori-0.5.11/extensions/apps.vala 2017-09-30 01:08:12.831916408 +0200
+@@ -265,7 +265,7 @@
+ store.get (iter, 0, out launcher);
+ try {
+ launcher.file.trash (null);
+- store.remove (iter);
++ store.remove (ref iter);
+
+ string filename = Midori.Download.clean_filename (launcher.name);
+ #if HAVE_WIN32
+diff -ur midori-0.5.11.orig/extensions/history-list.vala midori-0.5.11/extensions/history-list.vala
+--- midori-0.5.11.orig/extensions/history-list.vala 2015-08-30 13:56:26.000000000 +0200
++++ midori-0.5.11/extensions/history-list.vala 2017-09-30 01:10:25.137904917 +0200
+@@ -223,7 +223,7 @@
+ FixMe: the retrun value of `Gtk.ListStore.remove` should be checked
+ Note: in some cases the return value of `Gtk.ListStore.remove` is wrong
+ */
+- model.remove (iter);
++ model.remove (ref iter);
+ this.browser.close_tab (view);
+ if (length > 2)
+ this.resize_treeview ();
+diff -ur midori-0.5.11.orig/extensions/notes.vala midori-0.5.11/extensions/notes.vala
+--- midori-0.5.11.orig/extensions/notes.vala 2015-08-30 13:56:26.000000000 +0200
++++ midori-0.5.11/extensions/notes.vala 2017-09-30 01:09:14.703911034 +0200
+@@ -116,7 +116,7 @@
+ if (current_note == note) {
+ current_note = null;
+ }
+- notes_list_store.remove (iter);
++ notes_list_store.remove (ref iter);
+ break;
+ }
+ } while (notes_list_store.iter_next (ref iter));
+diff -ur midori-0.5.11.orig/extensions/transfers.vala midori-0.5.11/extensions/transfers.vala
+--- midori-0.5.11.orig/extensions/transfers.vala 2015-08-30 13:56:26.000000000 +0200
++++ midori-0.5.11/extensions/transfers.vala 2017-09-30 01:05:00.916933075 +0200
+@@ -275,7 +275,7 @@
+ Transfer found;
+ store.get (iter, 0, out found);
+ if (transfer == found) {
+- store.remove (iter);
++ store.remove (ref iter);
+ break;
+ }
+ } while (store.iter_next (ref iter));
+@@ -455,7 +455,7 @@
+ if (notifications.length () == 1)
+ msg = _("The file '<b>%s</b>' has been downloaded.").printf (filename);
+ else
+- msg = _("'<b>%s</b>' and %d other files have been downloaded.").printf (filename, notifications.length ());
++ msg = _("'<b>%s</b>' and %d other files have been downloaded.").printf (filename, (int) notifications.length ());
+ get_app ().send_notification (_("Transfer completed"), msg);
+ notifications = new GLib.List<string> ();
+ }
+diff -ur midori-0.5.11.orig/midori/midori-notebook.vala midori-0.5.11/midori/midori-notebook.vala
+--- midori-0.5.11.orig/midori/midori-notebook.vala 2015-08-30 13:56:26.000000000 +0200
++++ midori-0.5.11/midori/midori-notebook.vala 2017-09-30 00:49:47.947012362 +0200
+@@ -10,7 +10,7 @@
+ */
+
+ namespace Midori {
+- protected class Tally : Gtk.EventBox {
++ internal class Tally : Gtk.EventBox {
+ public Midori.Tab tab { get; set; }
+ Gtk.Spinner spinner;
+ public Gtk.Label label;
+@@ -22,7 +22,7 @@
+ public bool close_button_left { get; set; default = false; }
+ public bool close_button_visible { get; set; default = false; }
+
+- protected Tally (Midori.Tab tab) {
++ internal Tally (Midori.Tab tab) {
+ this.tab = tab;
+ box = new Gtk.HBox (false, 1);
+ add (box);
+@@ -155,7 +155,7 @@
+ int last_tab_size = 0;
+
+ #if !HAVE_GTK3
+- static const string style_fixup = """
++ const string style_fixup = """
+ style "midori-close-button-style"
+ {
+ GtkWidget::focus-padding = 0
+
diff --git a/www-client/midori/midori-0.5.11-r2.ebuild b/www-client/midori/midori-0.5.11-r2.ebuild
new file mode 100644
index 0000000..293c117
--- /dev/null
+++ b/www-client/midori/midori-0.5.11-r2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE='threads(+)'
+
+inherit gnome2 pax-utils python-any-r1 cmake-utils vala
+
+DESCRIPTION="A lightweight web browser based on WebKitGTK+"
+HOMEPAGE="http://www.midori-browser.org/"
+SRC_URI="http://www.${PN}-browser.org/downloads/${PN}_${PV}_all_.tar.bz2"
+
+KEYWORDS="~amd64 ~arm ~mips x86 ~x86-fbsd"
+
+LICENSE="LGPL-2.1 MIT"
+SLOT="0"
+IUSE="doc granite xscreensaver +jit zeitgeist"
+
+RDEPEND="
+ >=app-crypt/gcr-3:=[gtk]
+ >=dev-db/sqlite-3.6.19:3
+ >=dev-libs/glib-2.32.3:2
+ dev-libs/libxml2
+ >=net-libs/libsoup-2.38:2.4
+ >=x11-libs/libnotify-0.7
+ xscreensaver? ( x11-libs/libXScrnSaver )
+ >=x11-libs/gtk+-3.10.0:3
+ >=net-libs/webkit-gtk-2.3.91:4[jit=]
+ granite? ( >=dev-libs/granite-0.2 )
+ zeitgeist? ( >=dev-libs/libzeitgeist-0.3.14 )
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ $(vala_depend)
+ dev-util/intltool
+ gnome-base/librsvg
+ sys-devel/gettext
+ doc? ( dev-util/gtk-doc )
+"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ eapply "${FILESDIR}"/${P}-libsoup.patch #587448
+ eapply "${FILESDIR}"/${P}-vala-syntax.patch #628108
+ gnome2_src_prepare
+ vala_src_prepare
+ sed -i -e '/^install/s:COPYING:HACKING TODO TRANSLATE:' CMakeLists.txt || die
+}
+
+src_configure() {
+ strip-linguas -i po
+
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DOCDIR=/usr/share/doc/${PF}
+ -DUSE_APIDOCS="$(usex doc)"
+ -DUSE_GRANITE="$(usex granite)"
+ -DUSE_ZEITGEIST="$(usex zeitgeist)"
+ -DUSE_XSCREENSAVER="$(usex xscreensaver)"
+ -DVALA_EXECUTABLE="${VALAC}"
+ -DUSE_GTK3=ON
+ -DHALF_BRO_INCOM_WEBKIT2=ON
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+}