aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <stephen.arnold42@gmail.com>2015-05-30 10:04:23 -0700
committerSteve Arnold <stephen.arnold42@gmail.com>2015-05-30 10:04:23 -0700
commit85566c87a7d5ce821016e756abf15a0c1b7285e4 (patch)
treee57e909fbec4ac7824f1359d070c2589f003710c /media-libs
parenthalf of cogl/clutter is now multilib-friendly (diff)
downloadarm-85566c87a7d5ce821016e756abf15a0c1b7285e4.tar.gz
arm-85566c87a7d5ce821016e756abf15a0c1b7285e4.tar.bz2
arm-85566c87a7d5ce821016e756abf15a0c1b7285e4.zip
updated libx264 flags and patch
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/x264/files/x264-0.0.20130912-cflags.patch54
-rw-r--r--media-libs/x264/x264-0.0.20140308.ebuild8
2 files changed, 59 insertions, 3 deletions
diff --git a/media-libs/x264/files/x264-0.0.20130912-cflags.patch b/media-libs/x264/files/x264-0.0.20130912-cflags.patch
new file mode 100644
index 0000000..c08a0d7
--- /dev/null
+++ b/media-libs/x264/files/x264-0.0.20130912-cflags.patch
@@ -0,0 +1,54 @@
+diff --git a/configure b/configure
+index 07796b1..afdda94 100755
+--- a/configure
++++ b/configure
+@@ -556,11 +556,6 @@ case $host_cpu in
+ if [[ "$asm" == auto && "$CFLAGS" != *-march* ]]; then
+ CFLAGS="$CFLAGS -march=i686"
+ fi
+- if [[ "$asm" == auto && "$CFLAGS" != *-mfpmath* ]]; then
+- CFLAGS="$CFLAGS -mfpmath=sse -msse"
+- fi
+- CFLAGS="-m32 $CFLAGS"
+- LDFLAGS="-m32 $LDFLAGS"
+ else
+ # icc on linux has various degrees of mod16 stack support
+ if [ $SYS = LINUX ]; then
+@@ -591,13 +586,8 @@ case $host_cpu in
+ x86_64)
+ ARCH="X86_64"
+ AS="yasm"
+- [ $compiler = GNU ] && CFLAGS="-m64 $CFLAGS" && LDFLAGS="-m64 $LDFLAGS"
+ if [ "$SYS" = MACOSX ]; then
+ ASFLAGS="$ASFLAGS -f macho64 -m amd64 -DPIC -DPREFIX"
+- if cc_check '' "-arch x86_64"; then
+- CFLAGS="$CFLAGS -arch x86_64"
+- LDFLAGS="$LDFLAGS -arch x86_64"
+- fi
+ elif [ "$SYS" = WINDOWS -o "$SYS" = CYGWIN ]; then
+ ASFLAGS="$ASFLAGS -f win32 -m amd64"
+ # only the GNU toolchain is inconsistent in prefixing function names with _
+@@ -605,7 +595,11 @@ case $host_cpu in
+ [ $compiler = GNU ] && LDFLAGS="$LDFLAGS -Wl,--nxcompat -Wl,--dynamicbase"
+ [ $compiler = GNU ] && RCFLAGS="--target=pe-x86-64 $RCFLAGS"
+ else
+- ASFLAGS="$ASFLAGS -f elf -m amd64"
++ if cpp_check "" "" "__ILP32__" ; then
++ ASFLAGS="$ASFLAGS -f elf -m x32"
++ else
++ ASFLAGS="$ASFLAGS -f elf -m amd64"
++ fi
+ fi
+ ;;
+ powerpc|powerpc64)
+@@ -971,10 +965,6 @@ if [ "$pic" = "yes" ] ; then
+ [ $SYS = SunOS -a "$ARCH" = "X86" ] && SOFLAGS="$SOFLAGS -mimpure-text"
+ fi
+
+-if [ "$debug" != "yes" -a "$gprof" != "yes" ]; then
+- CFLAGS="$CFLAGS -fomit-frame-pointer"
+-fi
+-
+ if [ "$strip" = "yes" ]; then
+ CFLAGS="$CFLAGS -s"
+ LDFLAGS="$LDFLAGS -s"
diff --git a/media-libs/x264/x264-0.0.20140308.ebuild b/media-libs/x264/x264-0.0.20140308.ebuild
index 65147a0..80360cf 100644
--- a/media-libs/x264/x264-0.0.20140308.ebuild
+++ b/media-libs/x264/x264-0.0.20140308.ebuild
@@ -23,7 +23,7 @@ SONAME="142"
SLOT="0/${SONAME}"
LICENSE="GPL-2"
-IUSE="10bit +interlaced neon opencl static-libs sse +threads"
+IUSE="10bit +interlaced neon opencl pic static-libs cpu_flags_x86_sse +threads"
ASM_DEP=">=dev-lang/yasm-1.2.0"
DEPEND="abi_x86_32? ( ${ASM_DEP} )
@@ -33,12 +33,14 @@ RDEPEND="opencl? ( >=virtual/opencl-0-r3[${MULTILIB_USEDEP}] )
abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r7
!app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
+EPATCH_OPTS="-F 3"
+
DOCS="AUTHORS doc/*.txt"
src_prepare() {
# Initial support for x32 ABI, bug #420241
# Avoid messing too much with CFLAGS.
- epatch "${FILESDIR}"/${PN}-cflags.patch
+ epatch "${FILESDIR}"/x264-0.0.20130912-cflags.patch
}
multilib_src_configure() {
@@ -58,7 +60,7 @@ multilib_src_configure() {
fi
# Upstream uses this, see the cflags patch
- use sse && append-flags "-msse" "-mfpmath=sse"
+ use cpu_flags_x86_sse && append-flags "-msse" "-mfpmath=sse"
"${S}/configure" \
--prefix="${EPREFIX}"/usr \