aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <stephen.arnold42@gmail.com>2015-04-26 16:06:19 -0700
committerSteve Arnold <stephen.arnold42@gmail.com>2015-04-26 16:06:19 -0700
commit07e6b98505d2df3d9b83b94bfac382953200eb02 (patch)
treec3243e55ea50d303848599a81431ce7fb3423e0e /media-libs/clutter
parentrepo metadata update (diff)
downloadarm-07e6b98505d2df3d9b83b94bfac382953200eb02.tar.gz
arm-07e6b98505d2df3d9b83b94bfac382953200eb02.tar.bz2
arm-07e6b98505d2df3d9b83b94bfac382953200eb02.zip
need latest clutter to match other stuff
Diffstat (limited to 'media-libs/clutter')
-rw-r--r--media-libs/clutter/Manifest1
-rw-r--r--media-libs/clutter/clutter-1.22.0.ebuild110
2 files changed, 111 insertions, 0 deletions
diff --git a/media-libs/clutter/Manifest b/media-libs/clutter/Manifest
new file mode 100644
index 0000000..7b98738
--- /dev/null
+++ b/media-libs/clutter/Manifest
@@ -0,0 +1 @@
+DIST clutter-1.22.0.tar.xz 5303728 SHA256 5225fef91f717118654a5b98e24f2018d09ca3c37d61ecff84f77069de0fbf54 SHA512 1290e29168c3a00bf4fb0685e6269f59c772b208b0bd126ad30d652674454d2043eca26ba8abb8021138a813404cb3ca75fb57e691e32957238488f3d77a1d5b WHIRLPOOL d3568f72147b5f5119dfd86f1ea76b4718e393e5916b737c833290ccfd91b49f6a273c72c643ae166fabfcdc85f772bb255a6a0c7a6817186e61298f20f3d6b9
diff --git a/media-libs/clutter/clutter-1.22.0.ebuild b/media-libs/clutter/clutter-1.22.0.ebuild
new file mode 100644
index 0000000..e65ad03
--- /dev/null
+++ b/media-libs/clutter/clutter-1.22.0.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 virtualx
+
+HOMEPAGE="https://wiki.gnome.org/Projects/Clutter"
+DESCRIPTION="Clutter is a library for creating graphical user interfaces"
+
+LICENSE="LGPL-2.1+ FDL-1.1+"
+SLOT="1.0"
+IUSE="aqua debug doc egl gtk +introspection test wayland +X"
+REQUIRED_USE="
+ || ( aqua wayland X )
+ wayland? ( egl )
+"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc x86"
+
+# NOTE: glx flavour uses libdrm + >=mesa-7.3
+# XXX: uprof needed for profiling
+# >=libX11-1.3.1 needed for X Generic Event support
+# do not depend on tslib, it does not build and is disable by default upstream
+RDEPEND="
+ >=dev-libs/glib-2.37.3:2
+ >=dev-libs/atk-2.5.3[introspection?]
+ >=dev-libs/json-glib-0.12[introspection?]
+ >=media-libs/cogl-1.18.0[introspection?,pango,wayland?]
+ >=x11-libs/cairo-1.12:=[aqua?,glib]
+ >=x11-libs/pango-1.30[introspection?]
+
+ virtual/opengl
+ x11-libs/libdrm:=
+
+ egl? (
+ >=dev-libs/libinput-0.8
+ media-libs/cogl[gles2,kms]
+ >=virtual/libgudev-136
+ x11-libs/libxkbcommon
+ )
+ gtk? ( >=x11-libs/gtk+-3.3.18:3[aqua?] )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6 )
+ X? (
+ media-libs/fontconfig
+ >=x11-libs/libX11-1.3.1
+ x11-libs/libXext
+ x11-libs/libXdamage
+ x11-proto/inputproto
+ >=x11-libs/libXi-1.3
+ >=x11-libs/libXcomposite-0.4 )
+ wayland? (
+ dev-libs/wayland
+ x11-libs/gdk-pixbuf:2 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.20
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ doc? (
+ >=dev-util/gtk-doc-1.20
+ >=app-text/docbook-sgml-utils-0.6.14[jadetex]
+ dev-libs/libxslt )
+ test? ( x11-libs/gdk-pixbuf )"
+
+# Tests fail with both swrast and llvmpipe
+# They pass under r600g or i965, so the bug is in mesa
+#RESTRICT="test"
+
+src_prepare() {
+ # We only need conformance tests, the rest are useless for us
+ sed -e 's/^\(SUBDIRS =\).*/\1 accessibility conform/g' \
+ -i tests/Makefile.am || die "am tests sed failed"
+ sed -e 's/^\(SUBDIRS =\)[^\]*/\1 accessibility conform/g' \
+ -i tests/Makefile.in || die "in tests sed failed"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # XXX: Conformance test suite (and clutter itself) does not work under Xvfb
+ # (GLX error blabla)
+ # XXX: Profiling, coverage disabled for now
+ # XXX: What about cex100/win32 backends?
+ gnome2_src_configure \
+ --disable-profile \
+ --disable-maintainer-flags \
+ --disable-gcov \
+ --disable-cex100-backend \
+ --disable-win32-backend \
+ --disable-tslib-input \
+ $(use_enable aqua quartz-backend) \
+ $(usex debug --enable-debug=yes --enable-debug=minimum) \
+ $(use_enable doc docs) \
+ $(use_enable egl egl-backend) \
+ $(use_enable egl evdev-input) \
+ $(use_enable gtk gdk-backend) \
+ $(use_enable introspection) \
+ $(use_enable test gdk-pixbuf) \
+ $(use_enable wayland wayland-backend) \
+ $(use_enable wayland wayland-compositor) \
+ $(use_enable X xinput) \
+ $(use_enable X x11-backend)
+}
+
+src_test() {
+ Xemake check -C tests/conform
+}