aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <stephen.arnold42@gmail.com>2016-03-01 22:19:44 -0800
committerSteve Arnold <stephen.arnold42@gmail.com>2016-03-01 22:19:44 -0800
commitd5c0de300a01b4c219095f0ec6b0dfcf4f3c6832 (patch)
tree54cc6dcb21239c30670cc01f04c3c4f3ede8896a
parentdev-lang/perl: add workaround for configure failure to detect libc functions ... (diff)
downloadarm-d5c0de300a01b4c219095f0ec6b0dfcf4f3c6832.tar.gz
arm-d5c0de300a01b4c219095f0ec6b0dfcf4f3c6832.tar.bz2
arm-d5c0de300a01b4c219095f0ec6b0dfcf4f3c6832.zip
consolidate fixes and move to nerdboy overlay
-rw-r--r--app-accessibility/brltty/Manifest1
-rw-r--r--app-accessibility/brltty/brltty-5.2.ebuild194
-rw-r--r--app-accessibility/brltty/files/brltty-5.2-fix-ldflags.patch56
-rw-r--r--app-accessibility/brltty/files/brltty-5.2-respect-AR.patch12
-rw-r--r--app-accessibility/brltty/files/brltty-5.2-udev.patch38
-rw-r--r--app-accessibility/brltty/files/brltty.rc13
-rw-r--r--app-accessibility/brltty/files/brltty.tmpfiles.conf1
-rw-r--r--app-accessibility/brltty/metadata.xml26
8 files changed, 0 insertions, 341 deletions
diff --git a/app-accessibility/brltty/Manifest b/app-accessibility/brltty/Manifest
deleted file mode 100644
index 6e11ab2..0000000
--- a/app-accessibility/brltty/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST brltty-5.2.tar.xz 2532684 SHA256 f1293940317a675d0eaeaf3f363bbfe4bfaa5225c2116123a61ce2d3c71943f7 SHA512 8e16701e9c9d776c76e3ad0cb4319b2753295fea229bd3f60cb0dffc0b6946037e6f98daafae873238c4eff90d4b8ddb697b7d425e700c5a098aba8fed9eed3f WHIRLPOOL 33fcf326be381309f2baa3f59807145a0ca3a614f32b0b27e4b76af1c1f46f6459f7be1d629002538588ce71ab017b52bfc642fc06aa2c3f883aba272e61f20e
diff --git a/app-accessibility/brltty/brltty-5.2.ebuild b/app-accessibility/brltty/brltty-5.2.ebuild
deleted file mode 100644
index dea845c..0000000
--- a/app-accessibility/brltty/brltty-5.2.ebuild
+++ /dev/null
@@ -1,194 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 )
-FINDLIB_USE="ocaml"
-
-inherit findlib eutils multilib toolchain-funcs java-pkg-opt-2 flag-o-matic \
- autotools udev systemd python-r1
-
-DESCRIPTION="Daemon that provides access to the Linux/Unix console for a blind person"
-HOMEPAGE="http://brltty.com/"
-SRC_URI="http://brltty.com/archive/${P}.tar.xz"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 x86"
-IUSE="+api +beeper bluetooth +contracted-braille doc +fm gpm iconv icu
- java +midi ncurses nls ocaml +pcm python usb +speech
- tcl X"
-REQUIRED_USE="doc? ( api )
- java? ( api )
- ocaml? ( api )
- python? ( api )
- tcl? ( api )"
-
-COMMON_DEP="bluetooth? ( net-wireless/bluez )
- gpm? ( >=sys-libs/gpm-1.20 )
- iconv? ( virtual/libiconv )
- icu? ( dev-libs/icu:= )
- python? ( ${PYTHON_DEPS} )
- ncurses? ( sys-libs/ncurses )
- nls? ( virtual/libintl )
- tcl? ( >=dev-lang/tcl-8.4.15:0= )
- usb? ( virtual/libusb:0 )
- X? ( x11-libs/libXaw )"
-DEPEND="virtual/pkgconfig
- java? ( >=virtual/jdk-1.4 )
- python? ( >=dev-python/cython-0.16[${PYTHON_USEDEP}] )
- ${COMMON_DEP}"
-RDEPEND="java? ( >=virtual/jre-1.4 )
- ${COMMON_DEP}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-fix-ldflags.patch \
- "${FILESDIR}"/${P}-udev.patch \
- "${FILESDIR}"/${P}-respect-AR.patch
-
- java-pkg-opt-2_src_prepare
-
- # The code runs `pkg-config` directly instead of locating a suitable
- # pkg-config wrapper (or respecting $PKG_CONFIG).
- sed -i \
- -e 's/\<pkg-config\>/${PKG_CONFIG:-pkg-config}/' \
- aclocal.m4 configure.ac || die
-
- # We run eautoconf instead of using eautoreconf because brltty uses
- # a custom build system that uses autoconf without the rest of the
- # autotools.
- eautoconf
- python_copy_sources
-}
-
-src_configure() {
- strip-flags "_BSD_SOURCE"
- append-cppflags -D_DEFAULT_SOURCE
-
- use ncurses && append-libs -ltinfo
-
- tc-export AR LD PKG_CONFIG
- # override prefix in order to install into /
- # braille terminal needs to be available as soon in the boot process as
- # possible
- # Also override localstatedir so that the lib/brltty directory is installed
- # correctly.
- # Disable stripping since we do that ourselves.
- local myconf=(
- --prefix=/
- --localedir=/usr/share/locale
- --includedir=/usr/include
- --localstatedir=/var
- --disable-stripping
- --with-install-root="${D}"
- --with-writable-directory="/run/brltty"
- $(use_enable api)
- $(use_with beeper beep-package)
- $(use_enable contracted-braille)
- $(use_with fm fm-package)
- $(use_enable gpm)
- $(use_enable iconv)
- $(use_enable icu)
- $(use_enable java java-bindings)
- $(use_with midi midi-package)
- $(use_enable nls i18n)
- $(use_enable ocaml ocaml-bindings)
- $(use_with pcm pcm-package)
- $(use_enable speech speech-support)
- $(use_enable tcl tcl-bindings)
- $(use_enable X x)
- $(use_with bluetooth bluetooth-package)
- $(use_with ncurses curses)
- $(use_with usb usb-package) )
-
- econf "${myconf[@]}"
-
- if use python; then
- myconf+=( $(use_enable python python-bindings ) )
-
- python_configure() {
- econf "${myconf[@]}"
- }
- python_foreach_impl run_in_build_dir python_configure
- fi
-}
-
-src_compile() {
- local JAVAC_CONF=""
- local OUR_JNI_FLAGS=""
- if use java; then
- OUR_JNI_FLAGS="$(java-pkg_get-jni-cflags)"
- JAVAC_CONF="${JAVAC} -encoding UTF-8 $(java-pkg_javac-args)"
- fi
-
- emake JAVA_JNI_FLAGS="${OUR_JNI_FLAGS}" JAVAC="${JAVAC_CONF}"
-
- if use python; then
- python_build() {
- cd "Bindings/Python" || die
- emake
- }
- python_foreach_impl run_in_build_dir python_build
- fi
-}
-
-src_install() {
- if use ocaml; then
- findlib_src_preinst
- fi
-
- emake OCAML_LDCONF= install
-
- if use python; then
- python_install() {
- cd "Bindings/Python" || die
- emake install
- }
- python_foreach_impl run_in_build_dir python_install
- fi
-
- if use java; then
- # make install puts the _java.so there, and no it's not $(get_libdir)
- rm -rf "${D}/usr/lib/java"
- java-pkg_doso Bindings/Java/libbrlapi_java.so
- java-pkg_dojar Bindings/Java/brlapi.jar
- fi
-
- insinto /etc
- doins Documents/brltty.conf
- udev_newrules Autostart/Udev/udev.rules 70-brltty.rules
- newinitd "${FILESDIR}"/brltty.rc brltty
- systemd_dounit Autostart/Systemd/brltty.service
- systemd_dotmpfilesd "${FILESDIR}/${PN}.tmpfiles.conf"
-
- libdir="$(get_libdir)"
- mkdir -p "${D}"/usr/${libdir}/
- mv "${D}"/${libdir}/*.a "${D}"/usr/${libdir}/
- gen_usr_ldscript libbrlapi.so
-
- cd Documents
- mv Manual-BRLTTY/English/BRLTTY.txt BRLTTY-en.txt
- mv Manual-BRLTTY/French/BRLTTY.txt BRLTTY-fr.txt
- mv Manual-BrlAPI/English/BrlAPI.txt BrlAPI-en.txt
- dodoc CONTRIBUTORS ChangeLog HISTORY README* TODO BRLTTY-*.txt
- dohtml -r Manual-BRLTTY
- if use doc; then
- dohtml -r Manual-BrlAPI
- dodoc BrlAPI-*.txt
- fi
-
- keepdir /var/lib/brlapi
- rmdir "${D}/run/brltty"
- rmdir "${D}/run"
-}
-
-pkg_postinst() {
- elog
- elog please be sure "${ROOT}"etc/brltty.conf is correct for your system.
- elog
- elog To make brltty start on boot, type this command as root:
- elog
- elog rc-update add brltty boot
-}
diff --git a/app-accessibility/brltty/files/brltty-5.2-fix-ldflags.patch b/app-accessibility/brltty/files/brltty-5.2-fix-ldflags.patch
deleted file mode 100644
index e60ea9a..0000000
--- a/app-accessibility/brltty/files/brltty-5.2-fix-ldflags.patch
+++ /dev/null
@@ -1,56 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -377,7 +377,7 @@
- case "${host_os}"
- in
- linux*|gnu*|openbsd*|freebsd*|kfreebsd*|netbsd*|*qnx*|cygwin*|mingw*|elf*)
-- brltty_mkmod_ld_make="-shared"
-+ brltty_mkmod_ld_make="-shared ${LDFLAGS}"
- ;;
- solaris*)
- brltty_mkmod_ld_make="-G"
-@@ -404,7 +404,7 @@
- esac
- if test "${GCC}" = "yes"
- then
-- brltty_cv_prog_mkmod="\$(CC) ${brltty_mkmod_gcc_make=-shared} BRLTTY_OPTIONS_LD2CC([${brltty_mkmod_ld_options}]) -o"
-+ brltty_cv_prog_mkmod="\$(CC) ${brltty_mkmod_gcc_make=-shared} ${LDFLAGS} BRLTTY_OPTIONS_LD2CC([${brltty_mkmod_ld_options}]) -o"
- else
- brltty_cv_prog_mkmod="\$(LD) ${brltty_mkmod_ld_make} ${brltty_mkmod_ld_options} -o"
- fi])
-@@ -414,7 +414,7 @@
- case "${host_os}"
- in
- linux*|gnu*|openbsd*|freebsd*|kfreebsd*|netbsd*|*qnx*|elf*)
-- brltty_mklib_ld_make="-shared"
-+ brltty_mklib_ld_make="-shared ${LDFLAGS}"
- brltty_mklib_ld_options="-soname"
- ;;
- solaris*)
-@@ -449,7 +449,7 @@
- esac
- if test "${GCC}" = "yes"
- then
-- brltty_cv_prog_mklib="\$(CC) ${brltty_mklib_gcc_make=-shared} BRLTTY_OPTIONS_LD2CC([${brltty_mklib_ld_options+${brltty_mklib_ld_options} <name>}]) -o"
-+ brltty_cv_prog_mklib="\$(CC) ${brltty_mklib_gcc_make=-shared} ${LDFLAGS} BRLTTY_OPTIONS_LD2CC([${brltty_mklib_ld_options+${brltty_mklib_ld_options} <name>}]) -o"
- else
- brltty_cv_prog_mklib="\$(LD) ${brltty_mklib_ld_make} ${brltty_mklib_ld_options+${brltty_mklib_ld_options} <name>} -o"
- fi])
---- a/Bindings/OCaml/Makefile.in
-+++ b/Bindings/OCaml/Makefile.in
-@@ -55,13 +55,13 @@
- all : $(OCAML_FILES)
-
- $(OCAML_CLIBS) : brlapi_stubs.$O brlapi
-- $(OCAMLMKLIB) $(API_LDFLAGS) -oc $(OCAML_LIB)_stubs brlapi_stubs.$O
-+ $(OCAMLMKLIB) -ldopt "$(LDFLAGS)" $(API_LDFLAGS) -oc $(OCAML_LIB)_stubs brlapi_stubs.$O
-
- $(OCAML_BCLIB) : $(OCAML_CLIBS) brlapi.cmo
- $(OCAMLC) -a $(OCAMLMKLIB_FLAGS) -o $(OCAML_LIB).cma brlapi.cmo
-
- $(OCAML_NCLIB) : $(OCAML_CLIBS) brlapi.cmx
-- $(OCAMLMKLIB) $(OCAMLMKLIBOPT_FLAGS) -o $(OCAML_LIB) brlapi.cmx
-+ $(OCAMLMKLIB) -ldopt "$(LDFLAGS)" $(OCAMLMKLIBOPT_FLAGS) -o $(OCAML_LIB) brlapi.cmx
-
- brlapi.cmi: brlapi.mli
- $(OCAMLC) -o $@ -c brlapi.mli
diff --git a/app-accessibility/brltty/files/brltty-5.2-respect-AR.patch b/app-accessibility/brltty/files/brltty-5.2-respect-AR.patch
deleted file mode 100644
index 95451dc..0000000
--- a/app-accessibility/brltty/files/brltty-5.2-respect-AR.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur brltty-5.2/Programs/Makefile.in brltty-5.2-new/Programs/Makefile.in
---- brltty-5.2/Programs/Makefile.in 2014-11-06 07:28:41.000000000 -0800
-+++ brltty-5.2-new/Programs/Makefile.in 2014-11-20 05:41:57.144219093 -0800
-@@ -434,7 +434,7 @@
- [ ! -f lib.def ] || mv lib.def $(API_DEF)
-
- $(API_ARC): $(API_CLIENT_OBJECTS)
-- ar rc $@ $(API_CLIENT_OBJECTS)
-+ $(AR) rc $@ $(API_CLIENT_OBJECTS)
- $(RANLIB) $@
-
- brlapi_client.$O:
diff --git a/app-accessibility/brltty/files/brltty-5.2-udev.patch b/app-accessibility/brltty/files/brltty-5.2-udev.patch
deleted file mode 100644
index a191cc1..0000000
--- a/app-accessibility/brltty/files/brltty-5.2-udev.patch
+++ /dev/null
@@ -1,38 +0,0 @@
---- Autostart/Udev/udev.rules.orig 2016-01-19 20:58:58.028677077 -0800
-+++ Autostart/Udev/udev.rules 2016-01-19 20:54:16.950366026 -0800
-@@ -34,7 +34,9 @@
- # Cebra [all models]
- # HIMS [Sync Braille]
- # HandyTech [FTDI chip]
--ENV{PRODUCT}=="403/6001/*", ENV{BRLTTY_BRAILLE_DRIVER}="at,ce,hm,ht", GOTO="brltty_usb_run"
-+# FT232R USB UART [sparkfun FTDI breakout]
-+## disabled for conflicts (uncomment if you really have FTDI braille device)
-+#ENV{PRODUCT}=="403/6001/*", ENV{BRLTTY_BRAILLE_DRIVER}="at,ce,hm,ht", GOTO="brltty_usb_run"
-
- # Device: 0403:DE58
- # Hedo [MobilLine]
-@@ -182,20 +184,22 @@
- # FreedomScientific [Focus Blue]
- ENV{PRODUCT}=="f4e/114/*", ENV{BRLTTY_BRAILLE_DRIVER}="fs", GOTO="brltty_usb_run"
-
-+# Seika rules are commented out, because they conflict with USB-to-serial
-+# converters.
- # Device: 10C4:EA60
- # Generic Identifier
- # Vendor: Cygnal Integrated Products, Inc.
- # Product: CP210x UART Bridge / myAVR mySmartUSB light
- # BrailleMemo [Pocket]
- # Seika [Braille Display]
--ENV{PRODUCT}=="10c4/ea60/*", ENV{BRLTTY_BRAILLE_DRIVER}="mm,sk", GOTO="brltty_usb_run"
-+#ENV{PRODUCT}=="10c4/ea60/*", ENV{BRLTTY_BRAILLE_DRIVER}="mm,sk", GOTO="brltty_usb_run"
-
- # Device: 10C4:EA80
- # Generic Identifier
- # Vendor: Cygnal Integrated Products, Inc.
- # Product: CP210x UART Bridge
- # Seika [Note Taker]
--ENV{PRODUCT}=="10c4/ea80/*", ENV{BRLTTY_BRAILLE_DRIVER}="sk", GOTO="brltty_usb_run"
-+#ENV{PRODUCT}=="10c4/ea80/*", ENV{BRLTTY_BRAILLE_DRIVER}="sk", GOTO="brltty_usb_run"
-
- # Device: 1148:0301
- # BrailleMemo [Smart]
diff --git a/app-accessibility/brltty/files/brltty.rc b/app-accessibility/brltty/files/brltty.rc
deleted file mode 100644
index 3afc5af..0000000
--- a/app-accessibility/brltty/files/brltty.rc
+++ /dev/null
@@ -1,13 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-command=/bin/brltty
-pidfile=/var/run/brltty.pid
-command_args="-P $pidfile -q"
-
-depend() {
- before *
- after clock
-}
diff --git a/app-accessibility/brltty/files/brltty.tmpfiles.conf b/app-accessibility/brltty/files/brltty.tmpfiles.conf
deleted file mode 100644
index 18cc402..0000000
--- a/app-accessibility/brltty/files/brltty.tmpfiles.conf
+++ /dev/null
@@ -1 +0,0 @@
-d /run/brltty 0755 root root -
diff --git a/app-accessibility/brltty/metadata.xml b/app-accessibility/brltty/metadata.xml
deleted file mode 100644
index e8e32d5..0000000
--- a/app-accessibility/brltty/metadata.xml
+++ /dev/null
@@ -1,26 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<herd>accessibility</herd>
- <use>
- <flag name="api">build brltty's application program interface</flag>
- <flag name="beeper">support the console tone generator</flag>
- <flag name="contracted-braille">support in-line contracted braille</flag>
- <flag name="fm">support for the sound card synthesizer</flag>
- <flag name="midi">support the musical instrument digital interface</flag>
- <flag name="pcm">support for sound card digital audio</flag>
- <flag name="speech">speech support</flag>
-</use>
-<longdescription lang="en">
-BRLTTY is a background process (daemon) which provides access to the Linux/Unix
-console (when in text mode) for a blind person using a refreshable braille
-display. It drives the braille display, and provides complete screen review
-functionality. Some speech capability has also been incorporated.
-</longdescription>
-<longdescription lang="ja">
-BRLTTYは、盲人用ブライユ点字ディスプレイのためのLinux/Unixコンソールを制御するバ
-ックグラウンド・プロセス(デーモン)です。ブライユ点字ディスプレイを動かし、その多
-機能な完全なスクリーン・レビューを提供します。幾つかの台詞読み上げ機能も統合され
-ています。
-</longdescription>
-</pkgmetadata>