aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <stephen.arnold42@gmail.com>2016-11-01 00:03:58 -0700
committerSteve Arnold <stephen.arnold42@gmail.com>2016-11-01 00:03:58 -0700
commit4ff95708bad943c956188af75ba6132121082f3d (patch)
tree95ee8c1a76596bb0186e2228e340f327ef88296d
parentwww-client/firefox: remove stale versions (diff)
downloadarm-4ff95708bad943c956188af75ba6132121082f3d.tar.gz
arm-4ff95708bad943c956188af75ba6132121082f3d.tar.bz2
arm-4ff95708bad943c956188af75ba6132121082f3d.zip
sys-devel/gcc: add stack-alignment patch to EPATCH_EXCLUDE
-rw-r--r--sys-devel/gcc/gcc-5.3.0.ebuild7
1 files changed, 2 insertions, 5 deletions
diff --git a/sys-devel/gcc/gcc-5.3.0.ebuild b/sys-devel/gcc/gcc-5.3.0.ebuild
index 8b4d211..5a0262d 100644
--- a/sys-devel/gcc/gcc-5.3.0.ebuild
+++ b/sys-devel/gcc/gcc-5.3.0.ebuild
@@ -34,11 +34,8 @@ if [[ ${CATEGORY} != cross-* ]] ; then
fi
src_prepare() {
- if has_version '<sys-libs/glibc-2.12' ; then
- ewarn "Your host glibc is too old; disabling automatic fortify."
- ewarn "Please rebuild gcc after upgrading to >=glibc-2.12 #362315"
- EPATCH_EXCLUDE+=" 10_all_default-fortify-source.patch"
- fi
+ EPATCH_EXCLUDE+="91_all_pr69140-msabi-stack-alignment.patch"
+ has_version '<sys-libs/glibc-2.12' && EPATCH_EXCLUDE+=" 10_all_default-fortify-source.patch"
if is_crosscompile ; then
EPATCH_EXCLUDE+=" 05_all_gcc-spec-env.patch"
fi