summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/metacity/metacity-2.14.1.ebuild')
-rw-r--r--x11-wm/metacity/metacity-2.14.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-wm/metacity/metacity-2.14.1.ebuild b/x11-wm/metacity/metacity-2.14.1.ebuild
new file mode 100644
index 000000000000..69c9df56add5
--- /dev/null
+++ b/x11-wm/metacity/metacity-2.14.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/metacity/metacity-2.14.1.ebuild,v 1.1 2006/03/17 23:59:10 compnerd Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="Gnome default windowmanager"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="xinerama"
+
+# not parallel-safe; see bug #14405
+MAKEOPTS="${MAKEOPTS} -j1"
+
+RDEPEND=">=x11-libs/gtk+-2.6
+ >=x11-libs/pango-1.2
+ >=gnome-base/gconf-2
+ >=dev-libs/glib-2.6
+ >=x11-libs/startup-notification-0.7
+ !x11-misc/expocity"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.28"
+
+USE_DESTDIR="1"
+DOCS="AUTHORS ChangeLog HACKING NEWS README *.txt doc/*.txt"
+
+
+pkg_setup() {
+ # Compositor is too unreliable
+ G2CONF="$(use_enable xinerama) --disable-compositor"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ einfo "Metacity & Xorg X11 with composite enabled may cause unwanted"
+ einfo "border effects"
+}