summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/gaim-encryption/gaim-encryption-3.0_beta4.ebuild')
-rw-r--r--x11-plugins/gaim-encryption/gaim-encryption-3.0_beta4.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-plugins/gaim-encryption/gaim-encryption-3.0_beta4.ebuild b/x11-plugins/gaim-encryption/gaim-encryption-3.0_beta4.ebuild
new file mode 100644
index 000000000000..b241f7e42ad4
--- /dev/null
+++ b/x11-plugins/gaim-encryption/gaim-encryption-3.0_beta4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaim-encryption/gaim-encryption-3.0_beta4.ebuild,v 1.1 2006/03/28 19:59:39 gothgirl Exp $
+
+inherit flag-o-matic debug eutils
+
+MY_PV="${PV/_beta/beta}"
+MY_P="${PN}-${MY_PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="GAIM Encryption PlugIn"
+HOMEPAGE="http://gaim-encryption.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=net-im/gaim-1.0.1
+ >=dev-libs/nss-3.11"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}/${MY_P}-configure.patch"
+ libtoolize --force --copy || die "failed running libtoolize"
+ aclocal || die "failed running aclocal"
+ WANT_AUTOCONF="2.59" autoconf || die "failed to run autoconf"
+}
+
+src_compile() {
+ strip-flags
+ replace-flags -O? -O2
+ econf || die "failed running configure"
+ emake -j1 || die "Make failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "Install failed"
+ dodoc CHANGELOG INSTALL NOTES README TODO VERSION WISHLIST
+}