summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/redshift/files/redshift-1.7-python-abi.patch')
-rw-r--r--x11-misc/redshift/files/redshift-1.7-python-abi.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-misc/redshift/files/redshift-1.7-python-abi.patch b/x11-misc/redshift/files/redshift-1.7-python-abi.patch
new file mode 100644
index 000000000000..34ed52faccbf
--- /dev/null
+++ b/x11-misc/redshift/files/redshift-1.7-python-abi.patch
@@ -0,0 +1,30 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Fri Jul 20 17:59:51 UTC 2012
+Subject: gentoo-specific patch to support multiple python abis
+
+--- src/gtk-redshift/Makefile.am
++++ src/gtk-redshift/Makefile.am
+@@ -1,21 +1,9 @@
+
+-if ENABLE_GUI
+-gtk_redshift_PYTHON = \
+- __init__.py \
+- utils.py \
+- statusicon.py
+-nodist_gtk_redshift_PYTHON = \
+- defs.py
+ gtk_redshiftdir = $(pythondir)/gtk_redshift
+
+ dist_bin_SCRIPTS = gtk-redshift
+-endif
+-
+-EXTRA_DIST = defs.py.in
+-CLEANFILES = defs.py
+-
+
+ # Local python definitions
+-defs.py: defs.py.in
++all-local: defs.py.in
+ sed -e "s|\@bindir\@|$(bindir)|g" \
+- -e "s|\@localedir\@|$(localedir)|g" $< > $@
++ -e "s|\@localedir\@|$(localedir)|g" $< > defs.py