summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/tevent/tevent-0.9.17.ebuild')
-rw-r--r--sys-libs/tevent/tevent-0.9.17.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-libs/tevent/tevent-0.9.17.ebuild b/sys-libs/tevent/tevent-0.9.17.ebuild
new file mode 100644
index 000000000000..172e23f11ef3
--- /dev/null
+++ b/sys-libs/tevent/tevent-0.9.17.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/tevent/tevent-0.9.17.ebuild,v 1.1 2012/09/23 18:44:44 vostorga Exp $
+
+EAPI=4
+PYTHON_DEPEND="2:2.4"
+
+inherit waf-utils python
+
+DESCRIPTION="Samba tevent library"
+HOMEPAGE="http://tevent.samba.org/"
+SRC_URI="http://samba.org/ftp/tevent/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=sys-libs/talloc-2.0.6[python]"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_install() {
+ waf-utils_src_install
+ insinto $(python_get_sitedir)
+ doins tevent.py
+}
+
+pkg_postinst() {
+ python_mod_optimize tevent.py
+}
+
+pkg_postrm() {
+ python_mod_cleanup tevent.py
+}