summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/lilo/lilo-22.1-r3.ebuild')
-rw-r--r--sys-boot/lilo/lilo-22.1-r3.ebuild69
1 files changed, 0 insertions, 69 deletions
diff --git a/sys-boot/lilo/lilo-22.1-r3.ebuild b/sys-boot/lilo/lilo-22.1-r3.ebuild
deleted file mode 100644
index 0ba9decd433b..000000000000
--- a/sys-boot/lilo/lilo-22.1-r3.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/lilo/lilo-22.1-r3.ebuild,v 1.1 2003/12/09 08:12:34 seemant Exp $
-
-inherit mount-boot
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Standard Linux boot loader"
-SRC_URI="ftp://metalab.unc.edu/pub/Linux/system/boot/lilo/${P}.tar.gz"
-HOMEPAGE="http://brun.dyndns.org/pub/linux/lilo/"
-
-SLOT="0"
-LICENSE="BSD"
-KEYWORDS="x86 -amd64 -ppc -sparc -alpha -mips"
-
-DEPEND=">=sys-devel/bin86-0.15.5"
-
-PROVIDE="virtual/bootloader"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- cp Makefile Makefile.orig
- sed -e "s:-g:${CFLAGS}:" Makefile.orig > Makefile
-}
-
-src_compile() {
- emake || die
-}
-
-src_install() {
- into /
- dosbin lilo
- into /usr
- dosbin keytab-lilo.pl
- dodir /boot
- insinto /boot
- doins boot-text.b boot-menu.b boot-bmp.b chain.b os2_d.b
- insinto /etc
- newins ${FILESDIR}/lilo.conf lilo.conf.example
- doman manPages/*.[5-8]
- dodoc CHANGES COPYING INCOMPAT QuickInst README*
-}
-
-pkg_preinst() {
- mount-boot_mount_boot_partition
- if [ ! -L $ROOT/boot/boot.b -a -f $ROOT/boot/boot.b ]
- then
- echo "Saving old boot.b..."
- mv $ROOT/boot/boot.b $ROOT/boot/boot.old;
- fi
-
- if [ ! -L $ROOT/boot/chain.b -a -f $ROOT/boot/chain.b ]
- then
- echo "Saving old chain.b..."
- mv $ROOT/boot/chain.b $ROOT/boot/chain.old;
- fi
-
- if [ ! -L $ROOT/boot/os2_d.b -a -f $ROOT/boot/os2_d.b ]
- then
- echo "Saving old os2_d.b..."
- mv $ROOT/boot/os2_d.b $ROOT/boot/os2_d.old;
- fi
-}
-
-pkg_postinst() {
- einfo "Activating boot-menu..."
- ln -sf boot-menu.b $ROOT/boot/boot.b
-}