summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/ifplugd/ifplugd-0.13.ebuild')
-rw-r--r--sys-apps/ifplugd/ifplugd-0.13.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-apps/ifplugd/ifplugd-0.13.ebuild b/sys-apps/ifplugd/ifplugd-0.13.ebuild
new file mode 100644
index 000000000000..f4fc87157139
--- /dev/null
+++ b/sys-apps/ifplugd/ifplugd-0.13.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ifplugd/ifplugd-0.13.ebuild,v 1.1 2003/03/17 15:24:17 wmertens Exp $
+
+DESCRIPTION="Brings up/down network automatically with cable detection"
+HOMEPAGE="http://www.stud.uni-hamburg.de/users/lennart/projects/ifplugd"
+SRC_URI="${HOMEPAGE}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=""
+#RDEPEND=""
+
+S=${WORKDIR}/ifplugd
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ perl -pi.orig -e 's:^CFLAGS=.*$:CFLAGS='"${CFLAGS}:" Makefile
+ perl -pi.orig -e 's:/etc/ifplugd/ifplugd.action:/usr/sbin/ifplugd.action:' ifplugd.c
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ dosbin ifplugd ${FILESDIR}/ifplugd.action ifstatus
+ doman ifplugd.8 ifstatus.8
+
+ dodir /etc/conf.d
+ mv ifplugd.conf ${D}/etc/conf.d/ifplugd
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/ifplugd
+
+ dodoc README SUPPORTED_DRIVERS FAQ NEWS
+}