summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/htop/htop-0.3.2.ebuild')
-rw-r--r--sys-apps/htop/htop-0.3.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/htop/htop-0.3.2.ebuild b/sys-apps/htop/htop-0.3.2.ebuild
new file mode 100644
index 000000000000..acd270a1a5df
--- /dev/null
+++ b/sys-apps/htop/htop-0.3.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/htop/htop-0.3.2.ebuild,v 1.1 2004/06/10 09:17:40 wschlich Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="interactive process viewer"
+HOMEPAGE="http://htop.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="debug"
+DEPEND="sys-libs/ncurses"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ use debug && {
+ append-flags -O -ggdb -DDEBUG
+ RESTRICT="${RESTRICT} nostrip"
+ }
+ econf || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc README ChangeLog TODO
+}