summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/harminv/harminv-1.3.1.ebuild')
-rw-r--r--sci-physics/harminv/harminv-1.3.1.ebuild36
1 files changed, 15 insertions, 21 deletions
diff --git a/sci-physics/harminv/harminv-1.3.1.ebuild b/sci-physics/harminv/harminv-1.3.1.ebuild
index 115a6e6a6ece..83f1888bd115 100644
--- a/sci-physics/harminv/harminv-1.3.1.ebuild
+++ b/sci-physics/harminv/harminv-1.3.1.ebuild
@@ -1,8 +1,12 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-physics/harminv/harminv-1.3.1.ebuild,v 1.2 2008/11/08 19:04:12 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/harminv/harminv-1.3.1.ebuild,v 1.3 2012/04/25 16:56:30 jlec Exp $
-inherit eutils autotools
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils eutils
DESCRIPTION="Extraction of complex frequencies and amplitudes from time series"
HOMEPAGE="http://ab-initio.mit.edu/harminv/"
@@ -11,28 +15,18 @@ SRC_URI="http://ab-initio.mit.edu/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
+IUSE="static-libs"
RDEPEND="virtual/lapack"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-configure.ac.patch
- eautoreconf
-}
-
-src_compile() {
- econf \
- --with-blas="$(pkg-config --libs blas)" \
- --with-lapack="$(pkg-config --libs lapack)" \
- || die "econf failed"
- emake || die "emake failed"
-}
+PATCHES=( "${FILESDIR}"/${P}-configure.ac.patch )
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS NEWS README || die "dodoc failed"
+src_configure() {
+ local myeconfargs=(
+ --with-blas="$(pkg-config --libs blas)"
+ --with-lapack="$(pkg-config --libs lapack)"
+ )
+ autotools-utils_src_configure
}