summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/gsl/gsl-1.8.ebuild')
-rw-r--r--sci-libs/gsl/gsl-1.8.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/sci-libs/gsl/gsl-1.8.ebuild b/sci-libs/gsl/gsl-1.8.ebuild
index 089951fc533f..102324d36fa4 100644
--- a/sci-libs/gsl/gsl-1.8.ebuild
+++ b/sci-libs/gsl/gsl-1.8.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/gsl-1.8.ebuild,v 1.1 2006/04/11 15:02:48 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/gsl-1.8.ebuild,v 1.2 2006/06/17 01:34:52 spyderous Exp $
-inherit flag-o-matic
+inherit eutils flag-o-matic autotools
DESCRIPTION="The GNU Scientific Library"
HOMEPAGE="http://www.gnu.org/software/gsl/"
@@ -15,6 +15,13 @@ IUSE=""
DEPEND="virtual/libc"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch ${FILESDIR}/gsl-1.6-deps.diff
+ eautoreconf
+}
+
src_compile() {
replace-cpu-flags k6 k6-2 k6-3 i586
filter-flags -ffast-math