summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/predict/predict-2.2.3.ebuild')
-rw-r--r--sci-astronomy/predict/predict-2.2.3.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/sci-astronomy/predict/predict-2.2.3.ebuild b/sci-astronomy/predict/predict-2.2.3.ebuild
index 9f24708adcda..7db04c880caf 100644
--- a/sci-astronomy/predict/predict-2.2.3.ebuild
+++ b/sci-astronomy/predict/predict-2.2.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/predict/predict-2.2.3.ebuild,v 1.5 2009/02/23 18:31:04 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/predict/predict-2.2.3.ebuild,v 1.6 2010/09/29 18:45:06 tomjbe Exp $
inherit toolchain-funcs eutils
@@ -22,6 +22,13 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-xforms.patch
+ # fix for buffer overflow (Bug #339109)
+ sed -i -e "s/netport\[6\]/netport\[7\]/g" predict.c || die
+ # fix some further array out of bounds errors
+ sed -i -e "s/satname\[ 26/satname\[ 25/g" \
+ clients/gsat-1.1.0/src/db.c || die
+ sed -i -e "s/satname\[ 26/satname\[ 25/g" \
+ clients/gsat-1.1.0/src/comms.c || die
}
src_compile() {