summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy/polipo/files/polipo-0.9.12-gentoo.patch')
-rw-r--r--net-proxy/polipo/files/polipo-0.9.12-gentoo.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-proxy/polipo/files/polipo-0.9.12-gentoo.patch b/net-proxy/polipo/files/polipo-0.9.12-gentoo.patch
new file mode 100644
index 000000000000..bb16036168c5
--- /dev/null
+++ b/net-proxy/polipo/files/polipo-0.9.12-gentoo.patch
@@ -0,0 +1,46 @@
+diff -Nru polipo-0.9.12.orig/Makefile polipo-0.9.12/Makefile
+--- polipo-0.9.12.orig/Makefile 2007-02-06 23:17:39.000000000 +0200
++++ polipo-0.9.12/Makefile 2007-02-08 11:32:00.000000000 +0200
+@@ -82,11 +82,6 @@
+ cp -f localindex.html $(TARGET)$(LOCAL_ROOT)/index.html
+
+ install.man: all
+- mkdir -p $(TARGET)$(MANDIR)/man1
+- mkdir -p $(TARGET)$(INFODIR)
+- cp -f polipo.man $(TARGET)$(MANDIR)/man1/polipo.1
+- cp polipo.info $(TARGET)$(INFODIR)/
+- install-info --info-dir=$(INFODIR) polipo.info
+
+
+ polipo.info: polipo.texi
+diff -Nru polipo-0.9.12.orig/polipo.h polipo-0.9.12/polipo.h
+--- polipo-0.9.12.orig/polipo.h 2007-02-06 23:17:39.000000000 +0200
++++ polipo-0.9.12/polipo.h 2007-02-08 11:32:00.000000000 +0200
+@@ -62,7 +62,9 @@
+ #if defined(__STDC_VERSION__) && __STDC_VERSION__ >= 199901L
+ /* nothing */
+ #elif defined(__GNUC__)
++#ifndef inline
+ #define inline __inline
++#endif
+ #if (__GNUC__ >= 3)
+ #define restrict __restrict
+ #else
+diff -Nru polipo-0.9.12.orig/server.c polipo-0.9.12/server.c
+--- polipo-0.9.12.orig/server.c 2007-02-06 23:17:39.000000000 +0200
++++ polipo-0.9.12/server.c 2007-02-08 11:32:00.000000000 +0200
+@@ -1832,10 +1832,10 @@
+ } else if(code < 400 &&
+ (content_range.from >= 0 || content_range.to >= 0 ||
+ content_range.full_length >= 0)) {
+- do_log(L_ERROR, "Range without partial content.\n");
+- httpServerAbort(connection, 1, 502,
+- internAtom("Range without partial content"));
+- goto fail;
++ do_log(L_WARN, "Range without partial content.\n");
++ content_range.from = -1;
++ content_range.to = -1;
++ content_range.full_length = -1;
+ } else if(code != 304 && code != 412) {
+ full_len = len;
+ }