summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-news/rsstool/rsstool-1.0.1_rc2.ebuild')
-rw-r--r--net-news/rsstool/rsstool-1.0.1_rc2.ebuild22
1 files changed, 13 insertions, 9 deletions
diff --git a/net-news/rsstool/rsstool-1.0.1_rc2.ebuild b/net-news/rsstool/rsstool-1.0.1_rc2.ebuild
index 6c2ef849d369..989b8892e166 100644
--- a/net-news/rsstool/rsstool-1.0.1_rc2.ebuild
+++ b/net-news/rsstool/rsstool-1.0.1_rc2.ebuild
@@ -1,13 +1,12 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-news/rsstool/rsstool-1.0.1_rc2.ebuild,v 1.1 2010/09/18 11:25:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-news/rsstool/rsstool-1.0.1_rc2.ebuild,v 1.2 2011/03/28 13:30:37 scarabeus Exp $
-EAPI="2"
+EAPI=4
-inherit eutils
+inherit eutils toolchain-funcs
-MY_PV=${PV/_}
-MY_P=${PN}-${MY_PV}
+MY_P=${PN}-${PV/_}
DESCRIPTION="cmdline tool to read, parse, merge, and write RSS (and Atom) feeds"
HOMEPAGE="http://rsstool.berlios.de/"
@@ -18,17 +17,22 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
IUSE=""
-RDEPEND="dev-libs/libxml2"
+RDEPEND="dev-libs/libxml2
+ net-misc/curl"
DEPEND="${RDEPEND}
app-arch/unzip"
S=${WORKDIR}/${MY_P}-src/src
src_prepare() {
- sed -i '1i#!/bin/bash' configure #141906
+ sed -i '1i#!/bin/bash' configure || die
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
}
src_install() {
- emake DESTDIR="${D}" BINDIR="/usr/bin" install || die
+ emake DESTDIR="${D}" BINDIR="/usr/bin" install
dohtml ../*.html
}