summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-nds/gq/gq-1.0_beta1-r1.ebuild')
-rw-r--r--net-nds/gq/gq-1.0_beta1-r1.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/net-nds/gq/gq-1.0_beta1-r1.ebuild b/net-nds/gq/gq-1.0_beta1-r1.ebuild
deleted file mode 100644
index ec9169903367..000000000000
--- a/net-nds/gq/gq-1.0_beta1-r1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/gq/gq-1.0_beta1-r1.ebuild,v 1.4 2005/12/14 23:54:49 weeve Exp $
-
-inherit eutils
-
-S=${WORKDIR}/${PN}-${PV/_/}
-DESCRIPTION="GTK-based LDAP client"
-
-SRC_URI="mirror://sourceforge/gqclient/${PN}-${PV/_/}.tar.gz"
-HOMEPAGE="http://www.biot.com/gq/"
-IUSE="kerberos jpeg nls ssl"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ppc ~sparc ~x86"
-
-RDEPEND=">=x11-libs/gtk+-2
- >=net-nds/openldap-2
- kerberos? ( app-crypt/mit-krb5 )
- jpeg? ( media-libs/gdk-pixbuf )
- ssl? ( dev-libs/openssl )
- dev-libs/libxml2
- dev-libs/glib
- sys-devel/gettext
- =dev-libs/atk-1*
- x11-libs/pango
- dev-libs/cyrus-sasl
- virtual/libc"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- sys-apps/gawk
- sys-devel/bison
- sys-devel/gcc"
-
-src_unpack() {
- unpack ${A} || die
- cd ${S} || die
-
- # This patch, written by Luca Scamoni, is from
- # http://sourceforge.net/tracker/index.php?func=detail&aid=1122365&group_id=3805&atid=103805
- epatch "${FILESDIR}/util.c.diff"
-
- # Fix timestamp skews
- touch aclocal.m4 configure `find . -name Makefile.in`
-
- if use amd64 ; then
- rm config.sub config.guess
- automake --add-missing --copy
- fi
-}
-
-src_compile() {
- local myconf="--enable-browser-dnd --enable-cache"
-
- use nls \
- && myconf="${myconf} --with-included-gettext" \
- || myconf="${myconf} --disable-nls"
-
- use kerberos && myconf="${myconf} --with-kerberos-prefix=/usr"
-
- econf $myconf || die "./configure failed"
-
- emake || die "Compilation failed"
-}
-
-src_install() {
- emake DESTDIR=${D} install || die "Installation failed"
- rm -f ${D}/usr/share/locale/locale.alias
- dodoc ABOUT-NLS AUTHORS ChangeLog COPYING NEWS README* TODO
-}