summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/wget/wget-1.8.2-r2.ebuild')
-rw-r--r--net-misc/wget/wget-1.8.2-r2.ebuild24
1 files changed, 10 insertions, 14 deletions
diff --git a/net-misc/wget/wget-1.8.2-r2.ebuild b/net-misc/wget/wget-1.8.2-r2.ebuild
index 555478377bae..2854be0316d7 100644
--- a/net-misc/wget/wget-1.8.2-r2.ebuild
+++ b/net-misc/wget/wget-1.8.2-r2.ebuild
@@ -1,45 +1,41 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.8.2-r2.ebuild,v 1.8 2003/07/06 09:13:30 kumba Exp $
-
-
-IUSE="ssl nls static ipv6"
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.8.2-r2.ebuild,v 1.9 2003/08/03 04:08:19 vapier Exp $
inherit gnuconfig
NPVER=20011209
-S=${WORKDIR}/${P}
DESCRIPTION="Network utility to retrieve files from the WWW"
HOMEPAGE="http://www.cg.tuwien.ac.at/~prikryl/wget.html"
SRC_URI="mirror://gnu/wget/${P}.tar.gz
http://www.biscom.net/~cade/away/wget-new-percentage/wget-new-percentage-cvs-${NPVER}.tar.gz
ipv6? mirror://gentoo/${P}-ipv6-debian.patch.bz2"
-RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )"
-DEPEND="nls? ( sys-devel/gettext )"
-
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="amd64 x86 ppc sparc alpha hppa arm mips"
+IUSE="ssl nls static ipv6 debug"
+
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )"
+DEPEND="nls? ( sys-devel/gettext )"
src_unpack() {
unpack ${A}
cd ${S}
- patch -p1 < ${FILESDIR}/${PF}-gentoo.diff || die
+ epatch ${FILESDIR}/${PF}-gentoo.diff
cd ${S}/src
- patch -p0 < ${WORKDIR}/wget-new-percentage/wnp-20011208-2.diff || die
+ epatch ${WORKDIR}/wget-new-percentage/wnp-20011208-2.diff
if use ipv6
then
cd ${S}
- patch -p1 < ${WORKDIR}/${P}-ipv6-debian.patch || die
+ epatch ${WORKDIR}/${P}-ipv6-debian.patch
fi
}
src_compile() {
-
# Make wget use up-to-date configure scripts
gnuconfig_update
@@ -47,7 +43,7 @@ src_compile() {
use nls || myconf="--disable-nls"
use ssl && myconf="${myconf} --with-ssl"
use ssl || myconf="${myconf} --without-ssl --disable-opie --disable-digest"
- [ -z "$DEBUG" ] && myconf="${myconf} --disable-debug"
+ use debug && myconf="${myconf} --disable-debug"
use ssl && CFLAGS="${CFLAGS} -I/usr/include/openssl"
./configure --prefix=/usr --sysconfdir=/etc/wget \
--infodir=/usr/share/info --mandir=usr/share/man $myconf || die