summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/obby/obby-0.4.0_rc2.ebuild')
-rw-r--r--net-libs/obby/obby-0.4.0_rc2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-libs/obby/obby-0.4.0_rc2.ebuild b/net-libs/obby/obby-0.4.0_rc2.ebuild
new file mode 100644
index 000000000000..5c3705eb3fee
--- /dev/null
+++ b/net-libs/obby/obby-0.4.0_rc2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/obby/obby-0.4.0_rc2.ebuild,v 1.1 2006/06/12 16:25:37 humpback Exp $
+
+#MY_P=${P/_rc/rc}
+#S=${WORKDIR}/${MY_P}
+inherit eutils
+
+DESCRIPTION="Library for collaborative text editing"
+HOMEPAGE="http://darcs.0x539.de/libobby"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="howl"
+SRC_URI="http://releases.0x539.de/${PN}/${P/_/}.tar.gz"
+
+DEPEND=">=net-libs/net6-1.3.0_rc2
+ >=dev-libs/libsigc++-2.0
+ >=dev-libs/gmp-4.1.4
+ howl? ( >=net-misc/howl-0.9.8 )"
+
+RDEPEND=""
+
+S=${WORKDIR}/${P/_/}
+
+src_unpack() {
+ unpack ${A}
+# cd ${S}
+# epatch ${FILESDIR}/dual_subscribe.patch
+}
+
+src_compile() {
+
+ local myconf
+ myconf="${myconf} --disable-tests"
+ use howl && myconf="${myconf} --with-howl"
+ econf ${myconf} || die "./configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}