summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/lcrzo/lcrzo-4.16.0.ebuild')
-rw-r--r--net-libs/lcrzo/lcrzo-4.16.0.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/net-libs/lcrzo/lcrzo-4.16.0.ebuild b/net-libs/lcrzo/lcrzo-4.16.0.ebuild
deleted file mode 100644
index 0d5410be67ad..000000000000
--- a/net-libs/lcrzo/lcrzo-4.16.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/lcrzo/lcrzo-4.16.0.ebuild,v 1.3 2003/02/13 14:18:14 vapier Exp $
-
-S=${WORKDIR}/${P}-src
-DESCRIPTION="Library of Ethernet, IP, UDP, TCP, ICMP, ARP and RARP protocols"
-HOMEPAGE="http://www.laurentconstantin.com/en/lcrzo/"
-SRC_URI="http://www.laurentconstantin.com/common/${PN}/download/v4/${P}-src.tgz"
-
-DEPEND="virtual/glibc net-libs/libpcap"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 sparc "
-
-src_unpack() {
- unpack ${A} ; cd ${S}/src
-
- # genemake checks that these directories exist...
- mv genemake genemake.orig
- sed -e "s:/usr/local/include:/usr/include:" \
- -e "s:/usr/local/lib:/usr/lib:" \
- -e "s:/usr/local/bin:/usr/bin:" \
- -e "s:/usr/local/man/man1:/usr/share/man/man1:" \
- -e "s:/usr/local/man/man3:/usr/share/man/man3:" \
- genemake.orig > genemake
-
- chmod 755 genemake
- ./genemake || die "problem creating Makefile"
-
- # plug in our CFLAGS and make it install into ${D}...
- mv Makefile Makefile.orig
- sed -e "s:^\(GCCOPT=\).*:\1${CFLAGS}:" \
- -e "s:^\(GCCOPTL=\).*:\1${CFLAGS}:" \
- -e "s:^\(GCCOPTP=\).*:\1${CFLAGS}:" \
- -e "s:^\(INSTINCLUDE=\):\1${D}:" \
- -e "s:^\(INSTLIB=\):\1${D}:" \
- -e "s:^\(INSTBIN=\):\1${D}:" \
- -e "s:^\(INSTMAN1=\):\1${D}:" \
- -e "s:^\(INSTMAN3=\):\1${D}:" \
- Makefile.orig > Makefile
-}
-
-src_compile() {
- make -C src || die "compile problem"
-}
-
-src_install() {
- dodir /usr/{bin,include,lib} /usr/share/man/{man1,man3}
- make -C src install || die
- dodoc doc/*.txt
-}