summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/lostirc/lostirc-0.4.1.ebuild')
-rw-r--r--net-irc/lostirc/lostirc-0.4.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-irc/lostirc/lostirc-0.4.1.ebuild b/net-irc/lostirc/lostirc-0.4.1.ebuild
new file mode 100644
index 000000000000..ddd89eddf243
--- /dev/null
+++ b/net-irc/lostirc/lostirc-0.4.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/lostirc/lostirc-0.4.1.ebuild,v 1.1 2004/08/14 12:15:40 swegener Exp $
+
+inherit base
+
+IUSE="kde gnome debug"
+DESCRIPTION="A simple but functional graphical IRC client"
+HOMEPAGE="http://lostirc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+RESTRICT="nomirror"
+SLOT="0"
+LICENSE="GPL-2"
+#KEYWORDS="~sparc"
+KEYWORDS="~x86 ~ppc ~amd64"
+
+RDEPEND="=dev-cpp/gtkmm-2.4*
+ >=dev-cpp/glibmm-2.4.4
+ =dev-libs/libsigc++-2.0*"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf \
+ $(use_with gnome) \
+ $(use_with kde) \
+ $(use_enable debug logdebug) \
+ || die "econf failed"
+ base_src_compile make
+}
+
+src_install() {
+ base_src_install
+ dodoc AUTHORS ChangeLog README TODO NEWS || die "dodoc failed"
+}