summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/ayttm/ayttm-0.4.4.ebuild')
-rw-r--r--net-im/ayttm/ayttm-0.4.4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-im/ayttm/ayttm-0.4.4.ebuild b/net-im/ayttm/ayttm-0.4.4.ebuild
new file mode 100644
index 000000000000..e549da552553
--- /dev/null
+++ b/net-im/ayttm/ayttm-0.4.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/ayttm/ayttm-0.4.4.ebuild,v 1.1 2003/10/28 11:37:58 usata Exp $
+
+IUSE="arts esd gnome nls"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Are you talking to me? - MSN, Jabber, IRC, ICQ, AIM, SMTP instant messenger"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://ayttm.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ media-libs/audiofile
+ arts? ( >=kde-base/arts-1.0.0 )
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.7 )
+ esd? ( >=media-sound/esound-0.2.28 )"
+
+src_compile() {
+
+ econf \
+ --enable-smtp \
+ --enable-xft \
+ `use_enable arts` \
+ `use_enable esd` \
+ `use_enable gnome` \
+ `use_enable nls` || die
+ emake || die
+
+}
+
+src_install () {
+
+ einstall || die
+ dodoc AUTHORS NEWS README TODO COPYING ChangeLog
+
+}