summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs/coda/coda-6.0.8.ebuild')
-rw-r--r--net-fs/coda/coda-6.0.8.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/net-fs/coda/coda-6.0.8.ebuild b/net-fs/coda/coda-6.0.8.ebuild
index 7a9afd50086d..c268c4bf5cf1 100644
--- a/net-fs/coda/coda-6.0.8.ebuild
+++ b/net-fs/coda/coda-6.0.8.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/coda-6.0.8.ebuild,v 1.2 2005/02/05 14:36:20 griffon26 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/coda-6.0.8.ebuild,v 1.3 2005/06/08 20:39:05 griffon26 Exp $
inherit eutils
IUSE="kerberos"
DESCRIPTION="Coda is an advanced networked filesystem developed at Carnegie Mellon Univ."
-HOMEPAGE="http://www.coda.cs.cmu.edu"
-SRC_URI="ftp://ftp.coda.cs.cmu.edu/pub/coda/src/${P}.tar.gz"
+HOMEPAGE="http://www.coda.cs.cmu.edu/"
+SRC_URI="http://www.coda.cs.cmu.edu/pub/coda/src/${P}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
@@ -16,7 +16,7 @@ KEYWORDS="x86 ~ppc"
# partly based on the deps suggested by Mandrake's RPM, and/or on my current versions
# Also, definely needs coda.h from linux-headers.
-DEPEND=">=sys-libs/lwp-1.12
+DEPEND="~sys-libs/lwp-1.12
>=net-libs/rpc2-1.25
>=sys-libs/rvm-1.10
>=sys-libs/db-3
@@ -33,7 +33,7 @@ DEPEND=">=sys-libs/lwp-1.12
# net-fs/coda-kernel
-RDEPEND=">=sys-libs/lwp-1.12
+RDEPEND="~sys-libs/lwp-1.12
>=net-libs/rpc2-1.25
>=sys-libs/rvm-1.10
>=sys-libs/db-3
@@ -227,6 +227,12 @@ pkg_config () {
# Start coda server
/etc/init.d/codasrv start || exit 1
+ # Workaround to increase the likelihood that the coda server finished
+ # starting up. Once there is a nicer way to detect this, it should
+ # probably be added to the codasrv init script.
+ # See http://www.coda.cs.cmu.edu/maillists/codalist/codalist-2004/6954.html
+ sleep 5
+
einfo "Creating root volume..."
# Create root volume
createvoloutput=`createvol_rep / ${FQDN} 2>&1 <<- EOF