summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/upnpscan/upnpscan-0.4-r1.ebuild')
-rw-r--r--net-analyzer/upnpscan/upnpscan-0.4-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-analyzer/upnpscan/upnpscan-0.4-r1.ebuild b/net-analyzer/upnpscan/upnpscan-0.4-r1.ebuild
new file mode 100644
index 000000000000..563171feec20
--- /dev/null
+++ b/net-analyzer/upnpscan/upnpscan-0.4-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/upnpscan/upnpscan-0.4-r1.ebuild,v 1.1 2010/10/22 01:34:13 jer Exp $
+
+EAPI="2"
+
+inherit autotools eutils
+
+DESCRIPTION="Scans the network for UPNP capable devices"
+HOMEPAGE="http://www.cqure.net/wp/upnpscan/"
+SRC_URI="http://www.cqure.net/tools/${PN}-v${PV}-src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cflags.patch
+ eautoreconf
+}
+
+src_compile() {
+ if use static ; then
+ econf || die
+ else
+ econf --enable-static=no || die
+ fi
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ dobin "${S}"/src/upnpscan || die
+}