summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/argus-clients/argus-clients-3.0.6.1.ebuild')
-rw-r--r--net-analyzer/argus-clients/argus-clients-3.0.6.1.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/net-analyzer/argus-clients/argus-clients-3.0.6.1.ebuild b/net-analyzer/argus-clients/argus-clients-3.0.6.1.ebuild
deleted file mode 100644
index 24ffc6437931..000000000000
--- a/net-analyzer/argus-clients/argus-clients-3.0.6.1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/argus-clients/argus-clients-3.0.6.1.ebuild,v 1.4 2012/07/04 07:18:51 jdhore Exp $
-
-EAPI=4
-inherit autotools eutils
-
-DESCRIPTION="Clients for net-analyzer/argus"
-HOMEPAGE="http://www.qosient.com/argus/"
-SRC_URI="http://qosient.com/argus/dev/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-IUSE="debug ft geoip mysql sasl tcpd"
-
-MY_CDEPEND="
- net-analyzer/rrdtool[perl]
- net-libs/libpcap
- sys-libs/ncurses
- sys-libs/readline
- ft? ( net-analyzer/flow-tools )
- geoip? ( dev-libs/geoip )
- mysql? ( virtual/mysql )
- sasl? ( dev-libs/cyrus-sasl )
-"
-
-RDEPEND="
- ${MY_CDEPEND}
-"
-
-DEPEND="
- ${MY_CDEPEND}
- sys-devel/bison
- sys-devel/flex
-"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-3.0.4.1-disable-tcp-wrappers-automagic.patch
- eautoreconf
-}
-
-src_configure() {
- use debug && touch .debug
- econf \
- $(use_with ft libft) \
- $(use_with geoip GeoIP /usr/) \
- $(use_with sasl) \
- $(use_with tcpd wrappers) \
- $(use_with mysql)
-}
-
-src_compile() {
- emake CCOPT="${CFLAGS} ${LDFLAGS}"
-}
-
-src_install() {
- # argus_parse.a and argus_common.a are supplied by net-analyzer/argus
- dobin bin/ra*
- dodoc ChangeLog CREDITS README CHANGES
- doman man/man{1,5}/*
-}