summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/mpv/mpv-9999.ebuild')
-rw-r--r--media-video/mpv/mpv-9999.ebuild66
1 files changed, 44 insertions, 22 deletions
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index 6f55fc458729..6b8918d00c65 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -1,36 +1,34 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mpv/mpv-9999.ebuild,v 1.69 2015/03/28 01:53:34 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mpv/mpv-9999.ebuild,v 1.70 2015/03/31 20:23:31 maksbotan Exp $
EAPI=5
+
+EGIT_REPO_URI="https://github.com/mpv-player/mpv.git"
+
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
PYTHON_REQ_USE='threads(+)'
+
inherit eutils python-any-r1 waf-utils pax-utils fdo-mime gnome2-utils
+[[ ${PV} == *9999* ]] && inherit git-r3
WAF_V="1.8.4"
DESCRIPTION="Media player based on MPlayer and mplayer2"
HOMEPAGE="http://mpv.io/"
SRC_URI="http://ftp.waf.io/pub/release/waf-${WAF_V}"
-DOCS=( README.md etc/example.conf etc/input.conf )
-
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/mpv-player/mpv.git"
- inherit git-r3
- KEYWORDS=""
-else
- SRC_URI+=" https://github.com/mpv-player/mpv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
- DOCS+=( RELEASE_NOTES )
-fi
+[[ ${PV} == *9999* ]] || \
+SRC_URI+=" https://github.com/mpv-player/mpv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
# See Copyright in source tarball and bug #506946. Waf is BSD, libmpv is ISC.
LICENSE="GPL-2+ BSD ISC"
SLOT="0"
+[[ ${PV} == *9999* ]] || \
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
IUSE="+alsa bluray bs2b cdio +cli doc-pdf dvb +dvd dvdnav egl +enca encode
+iconv jack jpeg ladspa lcms +libass libav libcaca libguess libmpv lua luajit
-openal +opengl oss pulseaudio pvr rubberband samba sdl selinux v4l vaapi vdpau
-vf-dlopen wayland +X xinerama +xscreensaver xv"
+openal +opengl oss pulseaudio pvr raspberry-pi rubberband samba sdl selinux v4l
+vaapi vdpau vf-dlopen wayland +X xinerama +xscreensaver xv"
REQUIRED_USE="
|| ( cli libmpv )
@@ -123,29 +121,51 @@ DEPEND="${RDEPEND}
RDEPEND+="
selinux? ( sec-policy/selinux-mplayer )
"
+DOCS=( Copyright README.md etc/example.conf etc/input.conf )
+[[ ${PV} == *9999* ]] || \
+DOCS+=( RELEASE_NOTES )
pkg_setup() {
- if ! use libass; then
+ if use !libass; then
+ ewarn
ewarn "You've disabled the libass flag. No OSD or subtitles will be displayed."
+ ewarn
fi
- if use libav; then
- einfo "You have enabled media-video/libav instead of media-video/ffmpeg."
- einfo "Upstream recommends media-video/ffmpeg, as some functionality is not"
- einfo "provided by media-video/libav. For more information see:"
- einfo " https://github.com/mpv-player/mpv/wiki/FFmpeg-versus-Libav"
+ if use openal; then
+ ewarn
+ ewarn "You've enabled the openal audio output which is fallback and is disabled by upstream."
+ ewarn
+ fi
+
+ if use sdl; then
+ ewarn
+ ewarn "You've enabled the sdl video and audio outputs which are fallbacks and are disabled by upstream."
+ ewarn
fi
einfo "For additional format support you need to enable the support on your"
einfo "libavcodec/libavformat provider:"
- einfo " media-video/ffmpeg or media-video/libav"
+ einfo " media-video/libav or media-video/ffmpeg"
+ einfo
+ einfo "Selected provider will affect mpv features and behaviour:"
+ einfo " https://github.com/mpv-player/mpv/wiki/FFmpeg-versus-Libav"
python-any-r1_pkg_setup
}
-src_prepare() {
+src_unpack() {
+ if [[ ${PV} == *9999* ]]; then
+ git-r3_src_unpack
+ else
+ default_src_unpack
+ fi
+
cp "${DISTDIR}"/waf-${WAF_V} "${S}"/waf || die
chmod 0755 "${S}"/waf || die
+}
+
+src_prepare() {
epatch_user
}
@@ -216,6 +236,8 @@ src_configure() {
$(usex vaapi "$(use_enable opengl vaapi-glx)" '--disable-vaapi-glx')
$(use_enable libcaca caca)
$(use_enable jpeg)
+ $(use_enable raspberry-pi rpi)
+ $(use_enable raspberry-pi rpi-gles)
# hwaccels
$(use_enable vaapi vaapi-hwaccel)