summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/terminatorx/Manifest4
-rw-r--r--media-sound/terminatorx/files/digest-terminatorx-3.801
-rw-r--r--media-sound/terminatorx/files/digest-terminatorx-3.811
-rw-r--r--media-sound/terminatorx/terminatorx-3.81.ebuild (renamed from media-sound/terminatorx/terminatorx-3.80.ebuild)40
4 files changed, 19 insertions, 27 deletions
diff --git a/media-sound/terminatorx/Manifest b/media-sound/terminatorx/Manifest
index 82e0e0a4f28f..1042f7915fa2 100644
--- a/media-sound/terminatorx/Manifest
+++ b/media-sound/terminatorx/Manifest
@@ -1,5 +1,5 @@
-MD5 4cc4045f68a315ff80884a98df7f35ac ChangeLog 944
-MD5 1d72c4669e54f892b4ae4357e40491cd terminatorx-3.81.ebuild 2052
+MD5 a85b7b30ccc572b415644f764b7e28cc ChangeLog 942
+MD5 6afbd39f5b205b9e14449f32a99dbac6 terminatorx-3.81.ebuild 2159
MD5 b9c48043c327fb9f0fcb5b04b721e337 files/terminatorx-3.80.GNOMEpresent.patch 25091
MD5 a2074d5d27b3b2d3006703af2a500c3f files/terminatorx-3.80.fixGnomeMakefile.patch 1032
MD5 ed6038ad12972f0534133cb65dff99a0 files/digest-terminatorx-3.81 68
diff --git a/media-sound/terminatorx/files/digest-terminatorx-3.80 b/media-sound/terminatorx/files/digest-terminatorx-3.80
deleted file mode 100644
index 3028f20de52c..000000000000
--- a/media-sound/terminatorx/files/digest-terminatorx-3.80
+++ /dev/null
@@ -1 +0,0 @@
-MD5 04ad737a0b555ea869c27960088a7872 terminatorX-3.80.tar.gz 482974
diff --git a/media-sound/terminatorx/files/digest-terminatorx-3.81 b/media-sound/terminatorx/files/digest-terminatorx-3.81
new file mode 100644
index 000000000000..554fd4395d23
--- /dev/null
+++ b/media-sound/terminatorx/files/digest-terminatorx-3.81
@@ -0,0 +1 @@
+MD5 a16839184500afd74467e49a2efe6a5d terminatorX-3.81.tar.gz 505489
diff --git a/media-sound/terminatorx/terminatorx-3.80.ebuild b/media-sound/terminatorx/terminatorx-3.81.ebuild
index 8dc47c4d584b..16ae3a1dbd57 100644
--- a/media-sound/terminatorx/terminatorx-3.80.ebuild
+++ b/media-sound/terminatorx/terminatorx-3.81.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/terminatorx/terminatorx-3.80.ebuild,v 1.1 2003/07/08 07:26:21 torbenh Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/terminatorx/terminatorx-3.81.ebuild,v 1.1 2003/09/20 06:55:55 jje Exp $
+
+inherit gnome2
MY_P=${P/terminatorx/terminatorX}
S=${WORKDIR}/${MY_P}
@@ -30,8 +32,10 @@ src_unpack() {
unpack ${A}
cd ${S}
- epatch ${FILESDIR}/terminatorx-3.80.GNOMEpresent.patch
- epatch ${FILESDIR}/terminatorx-3.80.fixGnomeMakefile.patch
+ # we need the omf fix, or else we get access violation
+ # errors related to sandbox
+ gnome2_omf_fix ${S}/doc/terminatorX-manual/C/Makefile.in
+
}
src_compile() {
@@ -56,9 +60,9 @@ src_compile() {
use sox \
&& myconf="${myconf} --enable-sox"
- WANT_AUTOMAKE_1_6=1 econf ${myconf}
+ econf ${myconf}
- make || die
+ emake || die
}
src_install() {
@@ -66,23 +70,11 @@ src_install() {
}
pkg_postinst() {
- echo "
-Since Version 3.73 terminatorX supports
-running suid root. If you install the terminatorX binary suid
-root with the following commands:
-
-> chown root /usr/bin/terminatorX
-> chmod u+s /usr/bin/terminatorX
-
-terminatorX will then create the engine thread with realtime
-priority.
-
-There is a small chance that a malicious attacker could
-utilize terminatorX to acquire root privileges if installed suid
-root, although it should require quite some effort to create an
-exploit for that. On the other hand realtime scheduling
-massively improves the playback performance. So depending on who
-can access your computer you will have to decide for yourself on
-performance vs security.
-"
+ einfo "Since Version 3.73 terminatorX supports running"
+ einfo "suid root. If you install the terminatorX binary"
+ einfo "suid root it will then create the engine thread"
+ einfo "with realtime priority."
+ ewarn "Please read http://www.terminatorx.cx/faq.html#11"
+ ewarn "for details and potential security risks."
}
+