summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/ario/ario-1.5.ebuild')
-rw-r--r--media-sound/ario/ario-1.5.ebuild77
1 files changed, 0 insertions, 77 deletions
diff --git a/media-sound/ario/ario-1.5.ebuild b/media-sound/ario/ario-1.5.ebuild
deleted file mode 100644
index cc775e080f75..000000000000
--- a/media-sound/ario/ario-1.5.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/ario/ario-1.5.ebuild,v 1.6 2012/05/05 08:05:30 mgorny Exp $
-
-EAPI=2
-inherit eutils gnome2-utils
-
-DESCRIPTION="a GTK2 MPD (Music Player Daemon) client inspired by Rythmbox"
-HOMEPAGE="http://ario-player.sourceforge.net"
-SRC_URI="mirror://sourceforge/${PN}-player/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="audioscrobbler dbus debug +idle libnotify nls python taglib zeroconf"
-
-RDEPEND=">=dev-libs/glib-2.14:2
- dev-libs/libunique:1
- dev-libs/libxml2:2
- media-libs/libmpdclient
- net-misc/curl
- net-libs/gnutls
- >=x11-libs/gtk+-2.16:2
- audioscrobbler? ( net-libs/libsoup:2.4 )
- dbus? ( dev-libs/dbus-glib )
- libnotify? ( x11-libs/libnotify )
- python? ( dev-python/pygtk:2
- dev-python/pygobject:2 )
- taglib? ( media-libs/taglib )
- zeroconf? ( net-dns/avahi )"
-DEPEND="${RDEPEND}
- dev-util/intltool
- virtual/pkgconfig
- sys-devel/gettext"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
-}
-
-src_configure() {
- econf \
- --disable-dependency-tracking \
- --disable-static \
- --disable-xmms2 \
- --enable-libmpdclient2 \
- --enable-search \
- --enable-playlists \
- --disable-deprecations \
- $(use_enable audioscrobbler) \
- $(use_enable dbus) \
- $(use_enable debug) \
- $(use_enable idle mpdidle) \
- $(use_enable libnotify notify) \
- $(use_enable nls) \
- $(use_enable python) \
- $(use_enable taglib) \
- $(use_enable zeroconf avahi)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog NEWS README TODO
-
- find "${D}" -name '*.la' -exec rm -f '{}' +
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}