summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-radio/ibp/ibp-0.21.ebuild')
-rw-r--r--media-radio/ibp/ibp-0.21.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/media-radio/ibp/ibp-0.21.ebuild b/media-radio/ibp/ibp-0.21.ebuild
index 341995878ea1..5b010c71544b 100644
--- a/media-radio/ibp/ibp-0.21.ebuild
+++ b/media-radio/ibp/ibp-0.21.ebuild
@@ -1,6 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-radio/ibp/ibp-0.21.ebuild,v 1.1 2010/09/12 11:15:53 tomjbe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-radio/ibp/ibp-0.21.ebuild,v 1.2 2010/10/19 07:57:36 tomjbe Exp $
+
+EAPI="2"
+
+inherit eutils
DESCRIPTION="Shows currently transmitting beacons of the International Beacon Project (IBP)"
HOMEPAGE="http://wwwhome.cs.utwente.nl/~ptdeboer/ham/${PN}.html"
@@ -16,11 +20,14 @@ RDEPEND="sys-libs/ncurses
DEPEND="${RDEPEND}
X? ( x11-misc/imake )"
-src_compile() {
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+}
+
+src_configure() {
if ( use X ) ;then
xmkmf || die " xmkmf failed"
fi
- emake || die
}
src_install() {