summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/xmms-dspectogram/xmms-dspectogram-1.2.ebuild')
-rw-r--r--media-plugins/xmms-dspectogram/xmms-dspectogram-1.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-plugins/xmms-dspectogram/xmms-dspectogram-1.2.ebuild b/media-plugins/xmms-dspectogram/xmms-dspectogram-1.2.ebuild
new file mode 100644
index 000000000000..995ce90c6a7b
--- /dev/null
+++ b/media-plugins/xmms-dspectogram/xmms-dspectogram-1.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-dspectogram/xmms-dspectogram-1.2.ebuild,v 1.1 2002/08/30 08:35:31 seemant Exp $
+
+MY_P=${PN/xmms-/}-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Dual spectral histogram visualization plugin for xmms"
+SRC_URI="http://hem.passagen.se/joakime/${MY_P}.tar.gz"
+HOMEPAGE="http://hem.passagen.se/joakime/linuxapp.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND="media-sound/xmms"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S} || die
+ # patch in DESTDIR support
+ patch -p0 < ${FILESDIR}/${MY_P}-destdir.patch || die
+}
+
+src_compile() {
+ # There is no configure script, but the
+ # Makefile does things (mostly) correctly.
+ make clean || die
+ emake OPT="$CFLAGS" || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README COPYING Changes
+}