summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/vdr-games/files/vdr-games-0.6.3-gentoo.diff')
-rw-r--r--media-plugins/vdr-games/files/vdr-games-0.6.3-gentoo.diff91
1 files changed, 91 insertions, 0 deletions
diff --git a/media-plugins/vdr-games/files/vdr-games-0.6.3-gentoo.diff b/media-plugins/vdr-games/files/vdr-games-0.6.3-gentoo.diff
new file mode 100644
index 000000000000..b78286768904
--- /dev/null
+++ b/media-plugins/vdr-games/files/vdr-games-0.6.3-gentoo.diff
@@ -0,0 +1,91 @@
+diff -ru games-0.6.1-orig/Makefile games-0.6.1/Makefile
+--- games-0.6.1-orig/Makefile 2005-11-20 16:53:33.000000000 +0100
++++ games-0.6.1/Makefile 2005-11-20 16:53:41.000000000 +0100
+@@ -13,7 +13,7 @@
+ VDROBJS = plugin.o
+ SDLOBJS = main.o
+ DEFINES = -DVERSION=\"$(VERSION)\"
+-CFLAGS = -g -pipe -O2 -Wall -Woverloaded-virtual
++#CFLAGS = -g -pipe -O2 -Wall -Woverloaded-virtual
+ LFLAGS = -pthread
+ VDRDIR = ../../..
+ LIBDIR = ../../lib
+diff -ru games-0.6.1-orig/minesweeper/Makefile games-0.6.1/minesweeper/Makefile
+--- games-0.6.1-orig/minesweeper/Makefile 2005-11-20 16:53:33.000000000 +0100
++++ games-0.6.1/minesweeper/Makefile 2005-11-20 16:54:19.000000000 +0100
+@@ -1,6 +1,6 @@
+ GAME = minesweeper
+ OBJS = minesweeper.o
+-CFLAGS = -g -pipe -O2 -Wall -Woverloaded-virtual
++#CFLAGS = -g -pipe -O2 -Wall -Woverloaded-virtual
+
+ all: $(OBJS)
+ @ar -r $(GAME).a $(OBJS)
+diff -ru games-0.6.1-orig/plugin.cpp games-0.6.1/plugin.cpp
+--- games-0.6.1-orig/plugin.cpp 2005-11-20 16:53:33.000000000 +0100
++++ games-0.6.1/plugin.cpp 2005-11-20 16:53:41.000000000 +0100
+@@ -1,5 +1,5 @@
+-#include <plugin.h>
+-#include <osd.h>
++#include <vdr/plugin.h>
++#include <vdr/osd.h>
+
+ extern int launcher_menu(char ***m);
+ extern int launcher_start(int g, int x, int y, int s, int c);
+diff -ru games-0.6.1-orig/screen.cpp games-0.6.1/screen.cpp
+--- games-0.6.1-orig/screen.cpp 2005-11-20 16:53:33.000000000 +0100
++++ games-0.6.1/screen.cpp 2005-11-20 16:53:41.000000000 +0100
+@@ -5,7 +5,7 @@
+ #ifdef SDL
+ #include <SDL.h>
+ #else
+- #include <osd.h>
++ #include <vdr/osd.h>
+ #endif
+
+ #include "defines.h"
+diff -ru games-0.6.1-orig/snake/Makefile games-0.6.1/snake/Makefile
+--- games-0.6.1-orig/snake/Makefile 2005-11-20 16:53:33.000000000 +0100
++++ games-0.6.1/snake/Makefile 2005-11-20 16:54:12.000000000 +0100
+@@ -1,6 +1,6 @@
+ GAME = snake
+ OBJS = snake.o
+-CFLAGS = -g -pipe -O2 -Wall -Woverloaded-virtual
++#CFLAGS = -g -pipe -O2 -Wall -Woverloaded-virtual
+
+ all: $(OBJS)
+ @ar -r $(GAME).a $(OBJS)
+diff -ru games-0.6.1-orig/tetris/Makefile games-0.6.1/tetris/Makefile
+--- games-0.6.1-orig/tetris/Makefile 2005-11-20 16:53:33.000000000 +0100
++++ games-0.6.1/tetris/Makefile 2005-11-20 16:54:06.000000000 +0100
+@@ -1,6 +1,6 @@
+ GAME = tetris
+ OBJS = tetris.o
+-CFLAGS = -g -pipe -O2 -Wall -Woverloaded-virtual
++#CFLAGS = -g -pipe -O2 -Wall -Woverloaded-virtual
+
+ all: $(OBJS)
+ @ar -r $(GAME).a $(OBJS)
+diff -ru games-0.6.1-orig/tictactoe/Makefile games-0.6.1/tictactoe/Makefile
+--- games-0.6.1-orig/tictactoe/Makefile 2005-11-20 16:53:33.000000000 +0100
++++ games-0.6.1/tictactoe/Makefile 2005-11-20 16:54:15.000000000 +0100
+@@ -1,6 +1,6 @@
+ GAME = tictactoe
+ OBJS = tictactoe.o
+-CFLAGS = -g -pipe -O2 -Wall -Woverloaded-virtual
++#CFLAGS = -g -pipe -O2 -Wall -Woverloaded-virtual
+
+ all: $(OBJS)
+ @ar -r $(GAME).a $(OBJS)
+diff -ru games-0.6.1-orig/tron/Makefile games-0.6.1/tron/Makefile
+--- games-0.6.1-orig/tron/Makefile 2005-11-20 16:53:33.000000000 +0100
++++ games-0.6.1/tron/Makefile 2005-11-20 16:53:55.000000000 +0100
+@@ -1,6 +1,6 @@
+ GAME = tron
+ OBJS = tron.o
+-CFLAGS = -g -pipe -O2 -Wall -Woverloaded-virtual
++#CFLAGS = -g -pipe -O2 -Wall -Woverloaded-virtual
+
+ all: $(OBJS)
+ @ar -r $(GAME).a $(OBJS)
+