summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/stk/files/stk-4.3.1-cflags-lib.patch')
-rw-r--r--media-libs/stk/files/stk-4.3.1-cflags-lib.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-libs/stk/files/stk-4.3.1-cflags-lib.patch b/media-libs/stk/files/stk-4.3.1-cflags-lib.patch
new file mode 100644
index 000000000000..91126d6ec299
--- /dev/null
+++ b/media-libs/stk/files/stk-4.3.1-cflags-lib.patch
@@ -0,0 +1,46 @@
+diff -up stk-4.3.1/src/Makefile.in.orig stk-4.3.1/src/Makefile.in
+--- stk-4.3.1/src/Makefile.in.orig 2007-12-07 07:25:42.000000000 +0100
++++ stk-4.3.1/src/Makefile.in 2008-07-03 23:31:43.000000000 +0200
+@@ -38,7 +38,7 @@ endif
+ CC = @CXX@
+ DEFS = @byte_order@
+ DEFS += @debug@
+-CFLAGS = @cflags@
++CFLAGS = @CFLAGS@
+ CFLAGS += @warn@ $(INCLUDE) -Iinclude
+
+ REALTIME = @realtime@
+diff -up stk-4.3.1/projects/demo/Makefile.in.orig stk-4.3.1/projects/demo/Makefile.in
+--- stk-4.3.1/projects/demo/Makefile.in.orig 2007-12-07 07:25:42.000000000 +0100
++++ stk-4.3.1/projects/demo/Makefile.in 2008-07-04 02:02:32.000000000 +0200
+@@ -33,7 +33,7 @@ vpath %.h $(INCLUDE)
+ CC = @CXX@
+ DEFS = @byte_order@
+ DEFS += @debug@
+-CFLAGS = @cflags@
++CFLAGS = @CFLAGS@
+ CFLAGS += @warn@ -I$(INCLUDE) -I../../src/include
+ LIBRARY = @LIBS@
+ LIBRARY += @frameworks@
+--- stk-4.3.1/projects/effects/Makefile.in.orig 2007-12-07 07:25:42.000000000 +0100
++++ stk-4.3.1/projects/effects/Makefile.in 2008-07-04 03:08:29.000000000 +0200
+@@ -22,7 +22,7 @@ vpath %.h $(INCLUDE)
+ CC = @CXX@
+ DEFS = @byte_order@
+ DEFS += @debug@
+-CFLAGS = @cflags@
++CFLAGS = @CFLAGS@
+ CFLAGS += @warn@ -I$(INCLUDE) -I../../src/include
+ LIBRARY = @LIBS@
+ LIBRARY += @frameworks@
+--- stk-4.3.1/projects/ragamatic/Makefile.in.orig 2007-12-07 07:25:42.000000000 +0100
++++ stk-4.3.1/projects/ragamatic/Makefile.in 2008-07-04 03:10:23.000000000 +0200
+@@ -23,7 +23,7 @@ vpath %.h $(INCLUDE)
+ CC = @CXX@
+ DEFS = @byte_order@
+ DEFS += @debug@
+-CFLAGS = @cflags@
++CFLAGS = @CFLAGS@
+ CFLAGS += @warn@ -I$(INCLUDE) -I../../src/include
+ LIBRARY = @LIBS@
+ LIBRARY += @frameworks@