summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/quvi/quvi-0.2.10.ebuild')
-rw-r--r--media-libs/quvi/quvi-0.2.10.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-libs/quvi/quvi-0.2.10.ebuild b/media-libs/quvi/quvi-0.2.10.ebuild
new file mode 100644
index 000000000000..bf6bbb04db2a
--- /dev/null
+++ b/media-libs/quvi/quvi-0.2.10.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/quvi/quvi-0.2.10.ebuild,v 1.1 2010/12/10 18:38:15 hanno Exp $
+
+EAPI=2
+
+inherit versionator
+
+DESCRIPTION="library for parsing video download links"
+HOMEPAGE="http://quvi.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/$(get_version_component_range 1-2)/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc examples test offensive static-libs"
+
+RDEPEND=">=net-misc/curl-7.18.0
+ dev-lang/lua[deprecated]"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+# tests fetch data from live websites, so it's rather normal that they
+# will fail
+RESTRICT="test"
+
+src_configure() {
+ econf \
+ --without-doc \
+ $(use_enable examples) \
+ $(use_enable offensive nsfw) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog README || die "dodoc failed"
+ use doc && dodoc doc/How*
+ find "${D}" -name '*.la' -delete
+}