summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/lensfun/files/lensfun-0.2.5_p153-pc.patch')
-rw-r--r--media-libs/lensfun/files/lensfun-0.2.5_p153-pc.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/media-libs/lensfun/files/lensfun-0.2.5_p153-pc.patch b/media-libs/lensfun/files/lensfun-0.2.5_p153-pc.patch
new file mode 100644
index 000000000000..a74acf8fe70d
--- /dev/null
+++ b/media-libs/lensfun/files/lensfun-0.2.5_p153-pc.patch
@@ -0,0 +1,17 @@
+Index: libs/lensfun/CMakeLists.txt
+===================================================================
+--- libs/lensfun/CMakeLists.txt (Revision 158)
++++ libs/lensfun/CMakeLists.txt (Arbeitskopie)
+@@ -26,3 +26,12 @@
+ RUNTIME DESTINATION ${BINDIR}
+ LIBRARY DESTINATION ${LIBDIR}
+ ARCHIVE DESTINATION ${LIBDIR})
++
++IF(UNIX AND NOT APPLE)
++ SET(CONF_VERSION "${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_MICRO}.${VERSION_BUGFIX}")
++ SET(CONF_LIBDIR "${CMAKE_INSTALL_LIBDIR}/")
++ SET(CONF_INCLUDEDIR "${CMAKE_INSTALL_PREFIX}/${INCLUDEDIR}/")
++ SET(CONF_LENSFUN_STATIC "")
++ CONFIGURE_FILE("lensfun.pc.in" "lensfun.pc" @ONLY)
++ INSTALL(FILES "${CMAKE_CURRENT_BINARY_DIR}/lensfun.pc" DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig")
++ENDIF(UNIX AND NOT APPLE)