summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-mta/netqmail/files')
-rw-r--r--mail-mta/netqmail/files/conf-common11
-rw-r--r--mail-mta/netqmail/files/conf-qmqpd5
-rw-r--r--mail-mta/netqmail/files/conf-qmtpd5
-rw-r--r--mail-mta/netqmail/files/conf-smtpd5
-rw-r--r--mail-mta/netqmail/files/genqmail-20080406-ldflags.patch13
-rw-r--r--mail-mta/netqmail/files/servercert.cnf4
6 files changed, 24 insertions, 19 deletions
diff --git a/mail-mta/netqmail/files/conf-common b/mail-mta/netqmail/files/conf-common
index 613193cc9773..008fe63c3076 100644
--- a/mail-mta/netqmail/files/conf-common
+++ b/mail-mta/netqmail/files/conf-common
@@ -1,6 +1,6 @@
#!/bin/bash
# Common Configuration file for all qmail daemons
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/netqmail/files/conf-common,v 1.1 2006/02/12 18:42:33 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/netqmail/files/conf-common,v 1.2 2013/05/27 00:45:52 robbat2 Exp $
# Qmail User IDS to run daemons as
QMAILDUID=$(id -u qmaild)
@@ -17,7 +17,7 @@ TCPSERVER_PORT=${SERVICE}
# you do not need to specify -x, -c, -u or -g in this variable as those are
# added later
-TCPSERVER_OPTS="-p -v"
+TCPSERVER_OPTS="-p -v -R"
# This tells tcpserver where to file the rules cdb file
[[ -d /etc/tcprules.d/ ]] && \
@@ -25,9 +25,10 @@ TCPSERVER_OPTS="-p -v"
[[ ! -f "${TCPSERVER_RULESCDB}" ]] && \
TCPSERVER_RULESCDB=/etc/tcp.${SERVICE}.cdb
-# we limit data and stack segments to 8mbytes, you may need to raise this if
-# you are using a filter in QMAILQUEUE
-SOFTLIMIT_OPTS="-m 16000000"
+# we limit data and stack segments to 32mbytes, you may need to raise this if
+# you are using a filter in QMAILQUEUE.
+# Per bug #403893 amd64 needs a higher limit.
+SOFTLIMIT_OPTS="-m 32000000"
# We don't have anything to set QMAILQUEUE to at the moment, so we leave it
# alone. Generally it is best to add this in your appropriate (usually SMTP)
diff --git a/mail-mta/netqmail/files/conf-qmqpd b/mail-mta/netqmail/files/conf-qmqpd
index b3622411dc3a..2b337d930772 100644
--- a/mail-mta/netqmail/files/conf-qmqpd
+++ b/mail-mta/netqmail/files/conf-qmqpd
@@ -1,5 +1,5 @@
# Configuration file for qmail-qmqpd
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/netqmail/files/conf-qmqpd,v 1.1 2006/02/12 18:42:33 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/netqmail/files/conf-qmqpd,v 1.2 2013/05/27 00:45:52 robbat2 Exp $
# Stuff to run before tcpserver
#QMAIL_TCPSERVER_PRE=""
@@ -8,8 +8,5 @@
# Stuff to after qmail-qmqpd
#QMAIL_QMQP_POST=""
-# this turns off the IDENT grab attempt on connecting
-TCPSERVER_OPTS="${TCPSERVER_OPTS} -R"
-
# I don't trust /etc/services to have obscure ports
TCPSERVER_PORT=628
diff --git a/mail-mta/netqmail/files/conf-qmtpd b/mail-mta/netqmail/files/conf-qmtpd
index 7116efc29672..6d6df72e6506 100644
--- a/mail-mta/netqmail/files/conf-qmtpd
+++ b/mail-mta/netqmail/files/conf-qmtpd
@@ -1,5 +1,5 @@
# Configuration file for qmail-qmtpd
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/netqmail/files/conf-qmtpd,v 1.1 2006/02/12 18:42:33 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/netqmail/files/conf-qmtpd,v 1.2 2013/05/27 00:45:52 robbat2 Exp $
# For more information on making your servers talk QMTP
# see http://cr.yp.to/im/mxps.html
@@ -11,8 +11,5 @@
# Stuff to after qmail-qmtpd
#QMAIL_QMTP_POST=""
-# this turns off the IDENT grab attempt on connecting
-TCPSERVER_OPTS="${TCPSERVER_OPTS} -R"
-
# I don't trust /etc/services to have obscure ports
TCPSERVER_PORT=209
diff --git a/mail-mta/netqmail/files/conf-smtpd b/mail-mta/netqmail/files/conf-smtpd
index cfbdad49a52d..d7cc2c3d3d59 100644
--- a/mail-mta/netqmail/files/conf-smtpd
+++ b/mail-mta/netqmail/files/conf-smtpd
@@ -1,5 +1,5 @@
# Configuration file for qmail-smtpd
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/netqmail/files/conf-smtpd,v 1.1 2006/02/12 18:42:33 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/netqmail/files/conf-smtpd,v 1.2 2013/05/27 00:45:52 robbat2 Exp $
# Stuff to run before tcpserver
#QMAIL_TCPSERVER_PRE=""
@@ -8,9 +8,6 @@
# Stuff to after qmail-smtpd
#QMAIL_SMTP_POST=""
-# this turns off the IDENT grab attempt on connecting
-TCPSERVER_OPTS="${TCPSERVER_OPTS} -R"
-
# fixcrio inserts missing CRs at the ends of lines. See:
# http://cr.yp.to/ucspi-tcp/fixcrio.html
# http://cr.yp.to/docs/smtplf.html
diff --git a/mail-mta/netqmail/files/genqmail-20080406-ldflags.patch b/mail-mta/netqmail/files/genqmail-20080406-ldflags.patch
new file mode 100644
index 000000000000..1eb334c259c1
--- /dev/null
+++ b/mail-mta/netqmail/files/genqmail-20080406-ldflags.patch
@@ -0,0 +1,13 @@
+diff -Nuar genqmail-20080406.orig/spp/Makefile genqmail-20080406/spp/Makefile
+--- genqmail-20080406.orig/spp/Makefile 2008-04-06 15:44:14.000000000 +0000
++++ genqmail-20080406/spp/Makefile 2013-05-27 00:37:58.687763457 +0000
+@@ -14,7 +14,7 @@
+ rm -f $(TARGETS)
+
+ $(RESOLV_OBJS):
+- $(CC) $(CFLAGS) -o $@ $@.c -lresolv
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $@.c -lresolv
+
+ $(SIMPLE_OBJS):
+- $(CC) $(CFLAGS) -o $@ $@.c
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $@.c
diff --git a/mail-mta/netqmail/files/servercert.cnf b/mail-mta/netqmail/files/servercert.cnf
index 735445eacc87..aa48938ea655 100644
--- a/mail-mta/netqmail/files/servercert.cnf
+++ b/mail-mta/netqmail/files/servercert.cnf
@@ -1,4 +1,4 @@
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/netqmail/files/servercert.cnf,v 1.1 2006/02/12 18:42:33 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/netqmail/files/servercert.cnf,v 1.2 2013/05/27 00:45:52 robbat2 Exp $
# This is the openssl config file to generate keys for qmail
[ req ]
@@ -6,7 +6,7 @@
# this should be a power of 2!
default_bits = 1024
# leave the rest of these alone!
-encrypt_key = yes
+encrypt_key = no
distinguished_name = req_dn
x509_extensions = cert_type
prompt = no