summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-misc/kerry/files')
-rw-r--r--kde-misc/kerry/files/digest-kerry-0.093
-rw-r--r--kde-misc/kerry/files/kerry-0.09-del-shortcut.patch12
-rw-r--r--kde-misc/kerry/files/kerry-0.09-gentoo.patch86
-rw-r--r--kde-misc/kerry/files/kerry-0.09-xdg-desktop.patch11
4 files changed, 112 insertions, 0 deletions
diff --git a/kde-misc/kerry/files/digest-kerry-0.09 b/kde-misc/kerry/files/digest-kerry-0.09
new file mode 100644
index 000000000000..3183e70551d2
--- /dev/null
+++ b/kde-misc/kerry/files/digest-kerry-0.09
@@ -0,0 +1,3 @@
+MD5 a5740a62194a10b8ee8c47acb5771820 kerry-0.09.tar.bz2 278768
+RMD160 a83b5e36d0c336899c7d6920747cd18987f505c9 kerry-0.09.tar.bz2 278768
+SHA256 421e8a9f8caac776f456039af512fdf92fc25ca3a040cad2c1fd7df513d17c81 kerry-0.09.tar.bz2 278768
diff --git a/kde-misc/kerry/files/kerry-0.09-del-shortcut.patch b/kde-misc/kerry/files/kerry-0.09-del-shortcut.patch
new file mode 100644
index 000000000000..a96574456687
--- /dev/null
+++ b/kde-misc/kerry/files/kerry-0.09-del-shortcut.patch
@@ -0,0 +1,12 @@
+--- kerry/src.orig/kerryapp.cpp 2006-02-10 14:59:58.000000000 +0100
++++ kerry/src/kerryapp.cpp 2006-03-21 10:35:07.000000000 +0100
+@@ -110,8 +110,7 @@
+ KGlobalAccel* keys = globalKeys;
+ keys->insert( "Program:kerry", i18n("Kerry Beagle Search") );
+
+- KShortcut showDialogShortcut = KShortcut(Key_F12);
+- showDialogShortcut.append( KKey( ALT+Key_Space) );
++ KShortcut showDialogShortcut = KShortcut(ALT+Key_Space);
+ keys->insert( "Show Kerry Dialog", i18n("Show Search Dialog"), QString::null, showDialogShortcut, showDialogShortcut, hitListWindow, SLOT(showSearchDialog()) );
+ keys->insert( "Search Primary Selection with Kerry", i18n("Search Primary Selection"), QString::null, CTRL+ALT+Key_Space, CTRL+ALT+Key_Space, this, SLOT(searchPrimarySelection()) );
+ globalKeys->readSettings();
diff --git a/kde-misc/kerry/files/kerry-0.09-gentoo.patch b/kde-misc/kerry/files/kerry-0.09-gentoo.patch
new file mode 100644
index 000000000000..2bbab21703b1
--- /dev/null
+++ b/kde-misc/kerry/files/kerry-0.09-gentoo.patch
@@ -0,0 +1,86 @@
+diff -ru kerry-0.09/src/beaglesearch.cpp kerry-0.09-double/src/beaglesearch.cpp
+--- kerry-0.09/src/beaglesearch.cpp 2006-02-14 05:07:44.000000000 -0600
++++ kerry-0.09-double/src/beaglesearch.cpp 2006-03-25 14:41:41.000000000 -0600
+@@ -83,6 +83,11 @@
+ { BeagleSearch::Website, "dc:title", 0 },
+ { BeagleSearch::Website, "Title", 0 },
+ { BeagleSearch::Note, "dc:title", 0 },
++// Gentoo ebuilds
++ { BeagleSearch::Ebuilds, "dc:title", I18N_NOOP("Title: %1")"<br>" },
++ { BeagleSearch::Ebuilds, "dc:description", I18N_NOOP("Description: %1")"<br>" },
++ { BeagleSearch::Ebuilds, "fixme:version", I18N_NOOP("Version: %1")"<br>" },
++ { BeagleSearch::Ebuilds, "dc:source", I18N_NOOP("Homepage: %1")"<br>" },
+ { BeagleSearch::Unknown, "dc:author", I18N_NOOP("Author: %1")"<br>" },
+ { BeagleSearch::Unknown, "dc:title", I18N_NOOP("Title: %1")"<br>" },
+ // Calendar
+@@ -148,6 +153,7 @@
+ { BeagleSearch::Website, 0, "Google", 0 },
+ { BeagleSearch::Website, 0, "WebHistory", 0 },
+ { BeagleSearch::Website, 0, 0, "beagle/x-konq-cache" },
++ { BeagleSearch::Ebuilds, "*.ebuild", 0, 0 },
+ { BeagleSearch::Unknown, "file://", "File", 0 }, // mimetype wildcard must be last
+ { 0, 0, 0, 0}
+ };
+@@ -330,7 +336,7 @@
+ #endif
+
+ for( uint i = 0; hitflavorinfos[i].tilegroup!=0; i++ ) {
+- if( (hitflavorinfos[i].uri == 0 || (*(result->uri)).startsWith(hitflavorinfos[i].uri)) &&
++ if( (hitflavorinfos[i].uri == 0 || (*(result->uri)).startsWith(hitflavorinfos[i].uri) || (hitflavorinfos[i].uri[0]=='*' && (*(result->uri)).endsWith(hitflavorinfos[i].uri+1))) &&
+ (hitflavorinfos[i].type == 0 || hitflavorinfos[i].type==result->hit_type) &&
+ (hitflavorinfos[i].mimetype == 0 || (*(result->mime_type)).startsWith(hitflavorinfos[i].mimetype))) {
+ result->tilegroup = (TileGroup)hitflavorinfos[i].tilegroup;
+diff -ru kerry-0.09/src/beaglesearch.h kerry-0.09-double/src/beaglesearch.h
+--- kerry-0.09/src/beaglesearch.h 2006-02-14 05:07:44.000000000 -0600
++++ kerry-0.09-double/src/beaglesearch.h 2006-03-25 14:41:41.000000000 -0600
+@@ -51,7 +51,8 @@
+ Conversations, // in combo box
+ Website, // in combo box
+ Feed,
+- Note
++ Note,
++ Ebuilds
+ };
+
+ typedef QValueList<QString> PropertyList;
+diff -ru kerry-0.09/src/searchdlg.cpp kerry-0.09-double/src/searchdlg.cpp
+--- kerry-0.09/src/searchdlg.cpp 2006-03-13 04:40:58.000000000 -0600
++++ kerry-0.09-double/src/searchdlg.cpp 2006-03-25 14:54:21.000000000 -0600
+@@ -669,6 +669,9 @@
+ case Website:
+ show = ( result->tilegroup == BeagleSearch::Website);
+ break;
++ case Ebuilds:
++ show = ( result->tilegroup == BeagleSearch::Ebuilds);
++ break;
+ default:
+ break;
+ }
+diff -ru kerry-0.09/src/searchdlg.h kerry-0.09-double/src/searchdlg.h
+--- kerry-0.09/src/searchdlg.h 2006-01-10 10:13:29.000000000 -0600
++++ kerry-0.09-double/src/searchdlg.h 2006-03-25 14:53:41.000000000 -0600
+@@ -42,7 +42,8 @@
+ Conversations,
+ Images,
+ Media,
+- Website
++ Website,
++ Ebuilds
+ };
+
+ enum SortType {
+diff -ru kerry-0.09/src/searchdlg_layout.ui kerry-0.09-double/src/searchdlg_layout.ui
+--- kerry-0.09/src/searchdlg_layout.ui 2006-03-25 14:37:22.000000000 -0600
++++ kerry-0.09-double/src/searchdlg_layout.ui 2006-03-25 14:54:05.000000000 -0600
+@@ -250,6 +250,11 @@
+ <string>Web Pages</string>
+ </property>
+ </item>
++ <item>
++ <property name="text">
++ <string>Ebuilds</string>
++ </property>
++ </item>
+ <property name="name">
+ <cstring>comboShow</cstring>
+ </property>
diff --git a/kde-misc/kerry/files/kerry-0.09-xdg-desktop.patch b/kde-misc/kerry/files/kerry-0.09-xdg-desktop.patch
new file mode 100644
index 000000000000..cecea4c4a613
--- /dev/null
+++ b/kde-misc/kerry/files/kerry-0.09-xdg-desktop.patch
@@ -0,0 +1,11 @@
+Index: kerry/src/Makefile.am
+===================================================================
+--- kerry.orig/src/Makefile.am
++++ kerry/src/Makefile.am
+@@ -38,5 +38,5 @@ autostart_DATA = kerry.autostart.desktop
+ shutdowndir = $(prefix)/shutdown
+ shutdown_SCRIPTS = beagled-shutdown.sh
+
+-kde_apps_DATA = kerry.desktop
++xdg_apps_DATA = kerry.desktop
+