summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/step')
-rw-r--r--kde-base/step/ChangeLog7
-rw-r--r--kde-base/step/step-4.2.1.ebuild26
2 files changed, 32 insertions, 1 deletions
diff --git a/kde-base/step/ChangeLog b/kde-base/step/ChangeLog
index 7e95bc646edb..d6dd66b8b44e 100644
--- a/kde-base/step/ChangeLog
+++ b/kde-base/step/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/step
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/step/ChangeLog,v 1.9 2009/02/17 14:35:15 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/step/ChangeLog,v 1.10 2009/03/04 22:59:08 alexxy Exp $
+
+*step-4.2.1 (04 Mar 2009)
+
+ 04 Mar 2009; Alexey Shvetsov <alexxy@gentoo.org> +step-4.2.1.ebuild:
+ Bump KDE 4.2.1
17 Feb 2009; Alexey Shvetsov <alexxy@gentoo.org> -step-4.1.4.ebuild:
Drop KDE 4.1.4
diff --git a/kde-base/step/step-4.2.1.ebuild b/kde-base/step/step-4.2.1.ebuild
new file mode 100644
index 000000000000..2b080b6dc41f
--- /dev/null
+++ b/kde-base/step/step-4.2.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/step/step-4.2.1.ebuild,v 1.1 2009/03/04 22:59:08 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdeedu"
+inherit kde4-meta
+
+DESCRIPTION="The KDE physics simulator"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="+gsl +qalculate"
+
+DEPEND=">=sci-mathematics/gmm-3.0
+ sci-libs/cln
+ gsl? ( >=sci-libs/gsl-1.9-r1 )
+ qalculate? ( >=sci-libs/libqalculate-0.9.5 )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with gsl GSL)
+ $(cmake-utils_use_with qalculate Qalculate)"
+
+ kde4-meta_src_configure
+}