summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/phonon-kde/phonon-kde-4.4.0.ebuild')
-rw-r--r--kde-base/phonon-kde/phonon-kde-4.4.0.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/kde-base/phonon-kde/phonon-kde-4.4.0.ebuild b/kde-base/phonon-kde/phonon-kde-4.4.0.ebuild
deleted file mode 100644
index cbcb187038a7..000000000000
--- a/kde-base/phonon-kde/phonon-kde-4.4.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/phonon-kde/phonon-kde-4.4.0.ebuild,v 1.2 2010/02/17 19:12:03 ssuominen Exp $
-
-EAPI="2"
-
-KMNAME="kdebase-runtime"
-KMMODULE="phonon"
-inherit kde4-meta
-
-DESCRIPTION="Phonon KDE Integration"
-HOMEPAGE="http://phonon.kde.org"
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-LICENSE="GPL-2"
-IUSE="alsa debug +xine"
-
-DEPEND="
- >=media-sound/phonon-4.3.80[xine?]
- alsa? ( media-libs/alsa-lib )
- !=media-sound/phonon-4.4_pre*
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-4.3.4-optional-alsa.patch
-)
-
-src_prepare() {
- kde4-meta_src_prepare
-
- # Don't build tests - they require OpenGL
- sed -e 's/add_subdirectory(tests)//' \
- -i phonon/CMakeLists.txt || die "Failed to disable tests"
-
-}
-
-src_configure() {
- mycmakeargs=(
- $(cmake-utils_use_with alsa)
- $(cmake-utils_use_with xine)
- )
-
- kde4-meta_src_configure
-}