summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kig/kig-4.6.5.ebuild')
-rw-r--r--kde-base/kig/kig-4.6.5.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/kde-base/kig/kig-4.6.5.ebuild b/kde-base/kig/kig-4.6.5.ebuild
new file mode 100644
index 000000000000..fd6338a09b49
--- /dev/null
+++ b/kde-base/kig/kig-4.6.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kig/kig-4.6.5.ebuild,v 1.1 2011/07/09 15:14:07 alexxy Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KDE_SCM="git"
+if [[ ${PV} == *9999 ]]; then
+ kde_eclass="kde4-base"
+else
+ KMNAME="kdeedu"
+ kde_eclass="kde4-meta"
+fi
+inherit ${kde_eclass}
+
+DESCRIPTION="KDE Interactive Geometry tool"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug kig-scripting"
+
+DEPEND="
+ kig-scripting? ( >=dev-libs/boost-1.32 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with kig-scripting BoostPython)
+ )
+
+ ${kde_eclass}_src_configure
+}