summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kalgebra/kalgebra-4.2.1.ebuild')
-rw-r--r--kde-base/kalgebra/kalgebra-4.2.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/kde-base/kalgebra/kalgebra-4.2.1.ebuild b/kde-base/kalgebra/kalgebra-4.2.1.ebuild
new file mode 100644
index 000000000000..05a672cf8fd5
--- /dev/null
+++ b/kde-base/kalgebra/kalgebra-4.2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalgebra/kalgebra-4.2.1.ebuild,v 1.1 2009/03/04 20:27:13 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdeedu"
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="MathML-based graph calculator for KDE."
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="debug +plasma readline"
+
+DEPEND="opengl? ( virtual/opengl )
+ readline? ( sys-libs/readline )"
+RDEPEND="${DEPEND}"
+
+KMEXTRACTONLY="libkdeedu/kdeeduui"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with readline Readline)
+ $(cmake-utils_use_with plasma Plasma)
+ $(cmake-utils_use_with opengl OpenGL)"
+
+ kde4-meta_src_configure
+}