summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-server/ut2004-ded/ut2004-ded-3355.ebuild')
-rw-r--r--games-server/ut2004-ded/ut2004-ded-3355.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/games-server/ut2004-ded/ut2004-ded-3355.ebuild b/games-server/ut2004-ded/ut2004-ded-3355.ebuild
new file mode 100644
index 000000000000..39bebdd4059d
--- /dev/null
+++ b/games-server/ut2004-ded/ut2004-ded-3355.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/ut2004-ded/ut2004-ded-3355.ebuild,v 1.1 2005/05/16 18:10:40 wolf31o2 Exp $
+
+inherit games
+
+DESCRIPTION="Unreal Tournament 2004 Linux Dedicated Server"
+HOMEPAGE="http://www.unrealtournament.com/"
+
+MY_P="dedicatedserver3339-bonuspack.zip"
+MY_P2="${PN/-ded}-lnxpatch${PV}.tar.bz2"
+SRC_URI="mirror://3dgamers/pub/3dgamers/games/unrealtourn2k4/${MY_P}
+ mirror://3dgamers/pub/3dgamers/games/unrealtourn2k4/${MY_P2}"
+
+LICENSE="ut2003"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RESTRICT="nostrip nomirror"
+
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
+pkg_setup() {
+ check_license || die "License check failed"
+ games_pkg_setup
+}
+
+src_install() {
+ einfo "This will take a while ... go get a pizza or something"
+
+ dodir ${dir}
+ cp -r ${S}/UT2004-Patch/* ${S}
+ rm -rf ${S}/UT2004-Patch
+ cp -r ${S}/* ${Ddir}
+
+ if use amd64 ; then
+ rm ${Ddir}/System/{ucc-bi{n,n-macosx}} \
+ || die "removing unused binaries"
+ mv ${Ddir}/System/ucc-bin-linux-amd64 ${Ddir}/System/ucc-bin \
+ || die "renaming ucc-bin-amd64 => ucc-bin"
+ else
+ rm ${Ddir}/System/{ucc-bin-{linux-amd64,macosx}} \
+ || die "removing unused binaries"
+ fi
+
+ fperms 0770 ${dir}/System/ucc-bin || die "fixing permissions on ucc-bin"
+ rm -f ${Ddir}/System/*.dll || die "removing windows dlls"
+ rm -f ${Ddir}/System/*.exe || die "removing windows exes"
+
+ prepgamesdirs
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/ut2004-ded.rc ut2004-ded
+}
+
+pkg_postinst() {
+ echo
+ einfo "The server can be started with the /etc/init.d/ut2004-ded init script."
+ echo
+ ewarn "You should take the time to edit the default server INI."
+ ewarn "Consult the INI Reference at http://unrealadmin.org/"
+ ewarn "for assistance in adjusting the following file:"
+ ewarn " /opt/ut2004-ded/System/Default.ini"
+ echo
+ ewarn "NOTE: To have your server authenticate properly to the"
+ ewarn " central server, you MUST visit the following site"
+ ewarn " and request a key. This is not required if you"
+ ewarn " want an unfindable private server. [DoUplink=False]"
+ echo
+ ewarn " http://unreal.epicgames.com/ut2004server/cdkey.php"
+ echo
+ games_pkg_postinst
+}