summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle/pingus/pingus-0.6.0-r1.ebuild')
-rw-r--r--games-puzzle/pingus/pingus-0.6.0-r1.ebuild33
1 files changed, 14 insertions, 19 deletions
diff --git a/games-puzzle/pingus/pingus-0.6.0-r1.ebuild b/games-puzzle/pingus/pingus-0.6.0-r1.ebuild
index df154a3a639f..68e14e21bf1c 100644
--- a/games-puzzle/pingus/pingus-0.6.0-r1.ebuild
+++ b/games-puzzle/pingus/pingus-0.6.0-r1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/pingus-0.6.0-r1.ebuild,v 1.16 2006/01/20 08:26:17 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/pingus/pingus-0.6.0-r1.ebuild,v 1.17 2006/11/04 04:56:55 nyhm Exp $
-inherit eutils flag-o-matic games
+WANT_AUTOCONF=latest
+WANT_AUTOMAKE=latest
+inherit autotools eutils flag-o-matic games
DESCRIPTION="free Lemmings clone"
HOMEPAGE="http://pingus.seul.org/"
@@ -13,24 +15,24 @@ SLOT="0"
KEYWORDS="-amd64 x86"
IUSE="nls opengl"
-DEPEND=">=media-libs/hermes-1.3.2-r2
+RDEPEND="media-libs/hermes
=dev-games/clanlib-0.6.5*
- >=dev-libs/libxml2-2.5.6"
+ dev-libs/libxml2
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-gcc.patch #28281 #63773
- autoconf || die "failed to update configure file in order to respect CFLAGS/LDFLAGS"
+ epatch "${FILESDIR}"/${P}-build.patch
+ AT_M4DIR=m4 eautoreconf
}
src_compile() {
- append-flags $(clanlib0.6-config --cflags)
- append-ldflags $(clanlib0.6-config --libs)
replace-flags -Os -O2
egamesconf \
- --with-bindir="${GAMES_BINDIR}" \
- --with-datadir="${GAMES_DATADIR_BASE}" \
$(use_enable nls) \
$(use_with opengl clanGL) \
|| die
@@ -38,15 +40,8 @@ src_compile() {
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS NEWS README TODO
- # pos install process ... FIXME
- mv "${D}/usr/games/games" "${D}/usr/games/bin"
- cd "${D}/usr/share/games"
- use nls && mv locale ../
- mv games/pingus .
- rm -rf games
- # end pos install process
- make_desktop_entry pingus "Pingus"
+ make_desktop_entry pingus Pingus
prepgamesdirs
}