summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk/expect/expect-5.42.1.ebuild')
-rw-r--r--dev-tcltk/expect/expect-5.42.1.ebuild21
1 files changed, 14 insertions, 7 deletions
diff --git a/dev-tcltk/expect/expect-5.42.1.ebuild b/dev-tcltk/expect/expect-5.42.1.ebuild
index 31425cf1a1b9..83502e16cc74 100644
--- a/dev-tcltk/expect/expect-5.42.1.ebuild
+++ b/dev-tcltk/expect/expect-5.42.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.42.1.ebuild,v 1.1 2004/11/10 07:37:34 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.42.1.ebuild,v 1.2 2004/12/21 11:27:46 eradicator Exp $
-inherit gnuconfig
+inherit eutils gnuconfig
DESCRIPTION="tool for automating interactive applications"
HOMEPAGE="http://expect.nist.gov/"
@@ -13,22 +13,28 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
IUSE="X doc"
-DEPEND=">=dev-lang/tcl-8.2
+RDEPEND=">=dev-lang/tcl-8.2
X? ( >=dev-lang/tk-8.2 )"
+DEPEND="${RDEPEND}
+ =sys-devel/autoconf-2.1*"
+
NON_MICRO_V=${P%.[0-9]}
S=${WORKDIR}/${NON_MICRO_V}
src_unpack() {
unpack ${A}
cd ${S}
+ epatch ${FILESDIR}/${P}-multilib.patch
sed -i 's#/usr/local/bin#/usr/bin#' expect.man
sed -i 's#/usr/local/bin#/usr/bin#' expectk.man
#stops any example scripts being installed by default
sed -i \
-e '/^install:/s/install-libraries //' \
- -e 's/^SCRIPTS_MANPAGES = /_&/' Makefile.in
+ -e 's/^SCRIPTS_MANPAGES = /_&/' \
+ Makefile.in
gnuconfig_update
+ WANT_AUTOCONF=2.1 autoconf
}
src_compile() {
@@ -43,13 +49,13 @@ src_compile() {
#tkv=$(grep TK_VER /usr/include/tk.h | sed 's/^.*"\(.*\)".*/\1/')
#configure needs to find the files tclConfig.sh and tclInt.h
- myconf="--with-tcl=/usr/lib --with-tclinclude=/usr/lib/tcl${tclv}/include/generic"
+ myconf="--with-tcl=/usr/$(get_libdir) --with-tclinclude=/usr/$(get_libdir)/tcl${tclv}/include/generic"
if use X; then
#--with-x is enabled by default
#configure needs to find the file tkConfig.sh and tk.h
#tk.h is in /usr/lib so don't need to explicitly set --with-tkinclude
- myconf="$myconf --with-tk=/usr/lib"
+ myconf="$myconf --with-tk=/usr/$(get_libdir)"
else
#configure knows that tk depends on X so just disable X
myconf="$myconf --without-x"
@@ -60,12 +66,13 @@ src_compile() {
}
src_install () {
+ dodir /usr/$(get_libdir)
make install INSTALL_ROOT=${D} || die "make install failed"
dodoc ChangeLog FAQ HISTORY NEWS README
local static_lib="lib${NON_MICRO_V/-/}.a"
- rm ${D}/usr/lib/${NON_MICRO_V/-/}/${static_lib}
+ rm ${D}/usr/$(get_libdir)/${NON_MICRO_V/-/}/${static_lib}
#install examples if 'doc' is set
if use doc; then